MKIII (1986.5-1992)

+ Post New Thread
Page 1 of 2 1 2 LastLast
Threads 1 to 35 of 63

Forum: MKIII (1986.5-1992)

For general discussion about topics relating to the MKIII.

Sub-Forums Last Post

  1. For technical information about modifications/repairs to the MKIII.

    Forum Actions:

    Forum Statistics:

    • Threads: 23,810
    • Posts: 213,974
    1. Info regarding swapping the JZ-series engine into the A70 chassis.

      Forum Actions:

      Forum Statistics:

      • Threads: 9,360
      • Posts: 106,110
  2. For frequently asked questions about the MKIII.

    Forum Actions:

    Forum Statistics:

    • Threads: 97
    • Posts: 1,731
  1. Sticky Thread Sticky: Your 1JZ-GTE And 2JZ-GTE Swap Guide For Dummies

    I have noticed a lot of the 1JZ information is not as accurate as it used to be. The common parts that are interchangeable with the 2JZ are the easy ones to find and we know they fit. In this thread I will list everything there is to know for us MKIII owners about doing a 1JZ-GTE and 2JZ-GTE Swap....

    Started by IBoughtASupra, 06-25-2013 10:09 PM
    2 Pages
    1 2
    • Replies: 29
    • Views: 38,481
    01-14-2017 07:29 PM Go to last post
  2. Sticky Thread Sticky: New To MKIII Section??? Rules, Info and Search Help Here.......

    I have edited and relocated some useful information to help alleviate some questions from new users. Please read below for basic information on how this forum operates and how to better access it. - Trey SEARCH HINTS/HELP- The Supraforums search feature can be very helpful in keeping the...

    Started by SupraTrey, 12-19-2012 03:43 PM
    • Replies: 1
    • Views: 12,155
    12-21-2012 04:05 AM Go to last post
  1. Mk3 7mgte aem v2 pnp starting issues

    I finally got my car to start on the aem v2 I got from driftmotion. After having a cam sensor that was shit I got it to sync and after a lot a lot of cranking it starts. The problem I'm having is the aem will stat sync but still takes way to long to start. once it warms up I shut it off and go to...

    Started by Jerry_BLN, 03-18-2013 08:30 PM
    • Replies: 20
    • Views: 3,968
    Today 12:45 PM Go to last post
  2. Bolt on 4-Piston front MB brakes & 2-Piston rear Evo brakes

    I wanted to share my brake upgrade. None of this information is brand new and can be found on another forum if you want to go threw over 70 pages of info. I wanted to make a one post with all the information needed. I recommend upgrading the front and rears together to keep a balance in the braking...

    Started by survyor2, 11-23-2015 08:00 AM
    3 Pages
    1 2 3
    • Replies: 69
    • Views: 10,480
    Today 09:32 AM Go to last post
  3. IC gauge removal 89 7MGTE

    Been looking for some information on how to remove the gauges from the actual IC. I know how to take out the IC but that's where everything ends. I don't see anything about removal of an actual gauge. Reason being is, I thought I had an overheating issue for two weeks. Comes to find out my gauge is...

    Started by JohnSilva82147, 03-20-2017 10:44 PM
    • Replies: 2
    • Views: 98
    Yesterday 08:25 PM Go to last post
  4. JZA70 won't start, injectors pulse 4 times then stop

    I've had this car for about 18 months now, imported it a year ago. Never really had any trouble til now. Nothing new has been done to the car in quite some time. The only thing that might play a factor is an oil change the day before (messed up some wiring maybe?), but that *seems* to just be...

    Started by LF902, 03-16-2017 09:01 PM
    • Replies: 6
    • Views: 160
    Yesterday 01:43 PM Go to last post
  5. Rod bearing play normal?

    I removed the caps and plastigauged them and they all came out right on spec. The only thing im not sure about is if this side to side play is normal? It doesnt move anywhere except side to side as the vid shows.

    Started by Jon91, 03-21-2017 05:54 PM
    • Replies: 4
    • Views: 106
    Yesterday 09:34 AM Go to last post
  6. Long forgotten but not dead

    Just passing through to say what's up to all you hard core MKIII owners. Brewt4ce OG being replaced with new OG 80k unmolested MKIII

    Started by QWIKSTRIKE, 12-03-2016 05:52 PM
    3 Pages
    1 2 3
    • Replies: 57
    • Views: 2,662
    Yesterday 06:32 AM Go to last post
  7. WTB dash cover and door trim 88

    trying to find door molding and a dash cover. let me know if you have one in good condition.

    Started by Stroked-7m, Yesterday 06:30 AM
    • Replies: 0
    • Views: 18
    Yesterday 06:30 AM Go to last post
  8. Uz mk3

    anyone still putting this V8 in the chassis anymore?

    Started by Lxne, 03-12-2017 07:16 PM
    2 Pages
    1 2
    • Replies: 25
    • Views: 595
    03-21-2017 11:26 AM Go to last post
  9. Properly swap a V160 6 speed transmission into A70 Supra.

    Hello everybody! It's been a while since I have posted some of my upgrades. Anyway, I was reading threads about swapping the V160 6 speed in the mk3 MA70 Supra running a JZ engine of course, and the information about it is quite poor , and no one HAS DONE IT PROPERLY unfortunately. I am not...

    Started by 2JZA70Claou, 12-31-2016 01:21 PM
    3 Pages
    1 2 3
    • Replies: 59
    • Views: 1,981
    03-21-2017 10:25 AM Go to last post
  10. Sheedy Built Supra

    This build has been over the course of 4 years of hard work and lots of money spent. it was posted on SM just because i didnt know of SF at the time, so ill be posting it here now too! http://www.supramania.com/forums/showthread.php?168421-7mgte-Hx35-Build lets start off at the beginning,...

    Started by sheedy126, 04-06-2016 10:00 PM
    4 Pages
    1 2 3 4
    • Replies: 77
    • Views: 4,151
    03-20-2017 09:30 PM Go to last post
  11. My Rookie Build Thread

    I bought an 88 N/A 5 spd hardtop that was a little rough for $400 several years ago. Owner told me it ran, but it did not. The steering wheel and column were straight broken off by the incredible hulk. The steering lock was on and there was no key for it, so getting it on the trailer SUCKED. ...

    Started by RasmussenBC, 03-17-2017 04:40 PM
    • Replies: 12
    • Views: 268
    03-20-2017 02:23 PM Go to last post
  12. Tremec t56 Magnum to work with speedo?

    Has anybody gotten the t56 magnum working with the oem speedo yet using some sort of adapters? Its the last thing I havent figured out and would like to keep the stock look instead of going digital.

    Started by Troniar24, 03-09-2017 07:44 PM
    • Replies: 1
    • Views: 147
    03-17-2017 05:07 PM Go to last post
  13. 110 Bosch Bypass valve

    I replaced my non functioning bypass valve with a Bosch 110 but it seems like most of the time it does not open soon enough or long enough to bypass the pressure because you can still here the air spinning the turbo backwards sometimes. Light throttle it seems to work fine, but medium to full...

    Started by jbrehmer88, 03-16-2017 01:19 PM
    • Replies: 10
    • Views: 243
    03-17-2017 02:43 PM Go to last post
  14. Connector pins for 7m-GTE harness

    We need to start something here for the 7M harness like the JZ engines have. The connectors on the 7M are just as crusty. Anyways, I'm trying to find the connector and pin for the Oil sender for a 7m that I'm transplanting to my JZ, the connector and pin are in foul shape from the donor...

    Started by ZaZZn, 03-12-2017 09:28 PM
    • Replies: 3
    • Views: 133
    03-17-2017 01:21 PM Go to last post
  15. Odd adjustable knob under intake?

    Okay, so I was cleaning my bay with a pressure washer, due to this little surprise-I'm-going-to-pop-when-you're-coming-home-from-work Bypass hose I have have done my engine bay many times and when I started my engine to move it, I had a misfire. Teardown to the plugs began. In my plug...

    Started by MK3TargaJames, 03-16-2017 05:40 PM
    • Replies: 2
    • Views: 154
    03-17-2017 02:47 AM Go to last post
  16. Reverse Light Switch Location on 87 Turbo 184 Trans

    I am just trying to figure out WHERE the reverse switch is located on a 87 TURBO Manual 154 tranny? There USED to be a picture posted from 12-22-2010 05:50 PM from SUPRA RICH , but there is just an icon now with a X in it , and Chrome browser just shows a little icon as well . Can...

    Started by suprasvoboda, 02-13-2017 03:26 PM
    • Replies: 7
    • Views: 228
    03-16-2017 09:48 PM Go to last post
  17. Booooost!

    Hey guys I know this has been asked a million times, but my 7mgte is in the shop getting built up right now, and I'm trying to save some money. I could go forged internals or stock replacement. What my question is, is how much psi of boost do you think a brand new stock replacement bottom end could...

    Started by dufresne143, 03-14-2017 11:03 AM
    • Replies: 10
    • Views: 304
    03-16-2017 04:17 PM Go to last post
  18. My '88 Build

    Guys, I'm new to the forums and just wanted to share some fruits from my labor done last weekend... 7MGTE, 88 rebuild is in progress. (Apologies if this isn't the correct place to share this) (morning it arrived)

    Started by RAFEVO, 02-08-2017 01:23 AM
    • Replies: 8
    • Views: 563
    03-15-2017 06:06 AM Go to last post
  19. Good gasket kit

    I was looking for a good gasket kit for my 7mge. I heard victor reinz was a good kit: http://www.ebay.com/itm/Victor-Reinz-FS5769-Toyota-Supra-W-2954Cc-7Mge-Eng-86-92-Head-Gasket-Set-/222170329870?hash=item33ba62330e:g:sWAAAOSwuzRXc~qw&vxp=mtr There is this one by a seller recommended by some...

    Started by Jon91, 03-13-2017 05:39 PM
    • Replies: 7
    • Views: 162
    03-14-2017 06:39 PM Go to last post
  20. 7m GTE Oil pressure plug and connector pin?

    Anyone know where to buy new ones of this? I can't seem to find any connectors/pins for this. I'm replacing virtually every connector and pin on my harness (well have done already) and this one is eluding me.

    Started by ZaZZn, 03-12-2017 01:53 PM
    • Replies: 7
    • Views: 147
    03-14-2017 03:21 PM Go to last post
  21. Awd mk3

    hey guys, i was wondering has anyone ever tried/ been successful at a custom fab AWD setup for an mk3 supra? i know it sounds rediculous, but its an adventure i wouldnt mind embarking. yes im serious, no im not joking. seriously.

    Started by ThatOguy, 02-25-2013 05:29 PM
    2 Pages
    1 2
    • Replies: 37
    • Views: 2,950
    03-13-2017 10:01 AM Go to last post
  22. Speedomter Gear Count Riddle

    I have an R154 here that the drive speedometer gear(the teeth on the output shaft) count was 11 teeth on and the driven gear(the gear you can unbolt from the trans) count was 33 teeth. Does anyone know what rear was in this car? The trans is from an 89 car so it is either a 3.91 or 3.73. It also...

    Started by joliroger4, 02-26-2007 10:24 PM
    2 Pages
    1 2
    • Replies: 35
    • Views: 1,632
    03-12-2017 01:34 PM Go to last post
  23. Oil.....Where is it going??

    First post on here guys, be nice. I picked up an 87 7mgte supra a few days ago with 230kms. Car had sat for the past 3 months due to winter before I bought it. Oil was full when I bought it. It was a 7 hour drive home, during which I took it easy for about half and then started boosting around and...

    Started by LarsWalther, 03-02-2017 11:37 PM
    • Replies: 20
    • Views: 482
    03-09-2017 11:32 AM Go to last post
  24. JZA70 loose wiring connector ID

    Can any of you tell me what either of these is/was? I can't find their mates. Did they plug into the AT before it was swapped? Seem to be coming out of ignition harness, but I can't find them on the wiring diagram I have.

    Started by LF902, 03-09-2017 09:12 AM
    • Replies: 1
    • Views: 104
    03-09-2017 10:00 AM Go to last post
  25. 87 7mgte Different coolant sensors

    Is the coolant temp sensor for the ecu the same as the one for the cold start temp sensor? Not saying they use the same sensor, just wondering if its the same part number for both. The problem I am having is that my motor was missing both the connector and had a broken sensor for the cold start one...

    Started by jbrehmer88, 03-07-2017 11:18 AM
    • Replies: 13
    • Views: 214
    03-08-2017 04:07 PM Go to last post
  26. distributor question- 7mge/7mgte

    I believe the distributors for turbo and non turbo are identical except for the electronics...trying to put my 7mge distributor into a newer and machined turbo head did not go well. (I had blown the HG and found a turbo head for my NA Supra) It as a terribly tight fit for some reason and the...

    Started by Dire, 02-28-2017 06:41 AM
    • Replies: 3
    • Views: 173
    03-07-2017 11:57 PM Go to last post
  27. 1988 Mark 3 III Supra having trouble starting up

    Hello everyone, I am a new member to the Supra scene and a new member to the car build scene as a matter of fact. I am currently a senior in high school and need to do a project on a topic of choice. I chose the "Automotive Customization" topic. Now for my project I am attempting to rebuild my...

    Started by nekrofeelyah, 02-24-2017 01:15 PM
    • Replies: 12
    • Views: 327
    03-07-2017 06:46 PM Go to last post
  28. Running rich...Need some help here.

    Hey guys I bought a mk3 7mgte about a week ago and it smells like fuel whenever it's running. Badly. Car has zero misfire, runs otherwise pretty well. But runs terribly rich. With the windows down all I smell is fuel, even when I'm not driving it hard. Im not sure how the fuel economy usually is on...

    Started by LarsWalther, 03-07-2017 12:56 PM
    • Replies: 0
    • Views: 73
    03-07-2017 12:56 PM Go to last post
  29. 7mge

    does anyone know of a good company that has a remanufactured cylinder head in stock?

    Started by ahuynh12, 03-06-2017 10:30 AM
    • Replies: 0
    • Views: 88
    03-06-2017 10:30 AM Go to last post
  30. Drewgo Manifold Is Coming Back! Possibly Limited Quantity

    So in the process of trying to get a QSV and find a decent open manifold I was directed to the Drewgo Manifold. I've been in contact with Drewgo and we chatted for a while about the history of it, what issues there were in the past, and if it would be possible to address some of these, maybe work...

    Started by bluebullet89, 11-13-2016 09:46 PM
    • Replies: 11
    • Views: 930
    03-06-2017 03:58 AM Go to last post
  31. Thermostat housing help ASAP

    1989 7MGTE turbo, Heres my problem, switching out the thermostat and the housing was cracked so decided to replace it. Went to take all the fittings out of the housing and all but the coolant temperature sending unit broke. I am replacing them all but I need to know what is what. I have the...

    Started by JohnSilva82147, 03-03-2017 08:49 PM
    • Replies: 2
    • Views: 163
    03-04-2017 12:43 PM Go to last post
  32. Very rich idle. Possibly broke maf or 02 sensor

    Hi guys I had something strange happen this morning. I was going to work and made a quick pull on the highway and as soon as I got off the throttle my afr went super rich. I'm getting 10s at idle and the car bogs a lot when driving around. Runs really rich, maybe limp mode? I'm thinking my 02...

    Started by Joe1234, 02-24-2017 07:08 AM
    • Replies: 20
    • Views: 431
    03-04-2017 12:40 PM Go to last post
  33. Rotary Supra build

    I have a 89 7M GE auto. I originally just wanted to do a manual trans swap but it's pretty hard to find a W58 ot R154 around where I live. So I've decided to go with a rotary swap instead of the usual uz jz ls swaps. I'm just not sure if I should go with a renesis REW or 20b

    Started by Lxne, 12-26-2016 08:22 AM
    • Replies: 23
    • Views: 1,278
    03-02-2017 10:54 PM Go to last post
  34. 89 7mge CEL and other issues.

    Hello all, I have an 89 7mge that, when the battery is connected, the check engine light is constantly on. It turns off as soon as you turn the ignition to "on". I tried putting a jumper between "T" and "E1" on the diagnostic port while the ignition is turned to "on", but I get nothing. Turn the...

    Started by ShawnC87, 02-28-2017 05:33 PM
    • Replies: 1
    • Views: 210
    03-01-2017 08:35 PM Go to last post
  35. Best choice of standalone ECU

    I am wondering what you guys think is the best ECU for the money. I was looking at the AEM one that driftmotion has going but I'm trying not to spend $1300. Is there any out there cheaper? Is anybody selling one? My build is 60-1 turbo, driftmotion manifold, downpipe, intercooler, 1200cc low...

    Started by dufresne143, 02-23-2017 12:54 AM
    2 Pages
    1 2
    • Replies: 29
    • Views: 922
    02-28-2017 10:52 AM Go to last post

+ Post New Thread
Page 1 of 2 1 2 LastLast

Forum Information and Options

Thread Display Options

Use this control to limit the display of threads to those newer than the specified time frame.

Allows you to choose the data by which the thread list will be sorted.

Order threads in...

Note: when sorting by date, 'descending order' will show the newest results first.

Icon Legend

Contains unread posts
Contains unread posts
Contains no unread posts
Contains no unread posts
More than 40 replies or 500 views
Hot thread with unread posts
More than 40 replies or 500 views
Hot thread with no unread posts
Closed Thread
Thread is closed
Thread Contains a Message Written By You
You have posted in this thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts