MKIV Technical

+ Post New Thread
Threads 1 to 22 of 22

Forum: MKIV Technical

For technical information about modifications/repairs to the MKIV.

  1. Sticky Thread Sticky: Diagnosing the Sequential System FAQ

    In the early 2000's I wrote a Seq. FAQ on how to diagnose Seq operation issues. This is a very common complaint Supra owners have and most just give up and go single! Plus our cars are getting older with a higher chance these issues are getting more prevalent. I have revamped my older version...

    Started by Stu Hagen, 06-12-2017 04:00 PM
    • Replies: 1
    • Views: 63
    06-13-2017 06:18 PM Go to last post
  2. Sticky Thread Sticky: New Wheel & Tire fitment guide.

    Please send me an e-mail if you would like a copy of the spreadsheet. sjarvis@triad.rr.com Later, Steve

    Started by Steve Jarvis, 11-05-2001 08:24 AM
    42 Pages
    1 2 3 4 5 6 ... 42
    • Replies: 1,039
    • Views: 165,672
    06-07-2017 08:49 PM Go to last post
  3. Sticky Thread Sticky: Free Car Service Manuals download free car repair manuals |online auto service manual

    I found this link on line ,tried it and it worked . hope it helps others NOTE:not all cars are there and not all links work but some good ones are there and work. http://carservicemanuals.blogspot.com/ here is the link for the 95&97 MKIV

    Started by Ranger498, 04-10-2010 10:55 AM
    • Replies: 16
    • Views: 253,978
    09-21-2016 07:20 AM Go to last post
  1. USDM Side Skirts?

    Hey, I've owned this 1994 Toyota Supra Turbo that I got from Japan for about 2 years now and I am just wondering where I could purchase the USDM Side Skirts. I currently have the JDM skirt package on which includes the rear spats and side skirts that are very similar to the Ridox skirts. The skirts...

    Started by pzvox, Yesterday 03:23 PM
    • Replies: 0
    • Views: 25
    Yesterday 03:23 PM Go to last post
  2. Not staying running, rough idle, oil on coil packs and spark plugs?

    Having issues getting my car to stay running. It cranks over and just dies. I got it to run yesterday, but the idle is very rough. I suspect the spark plugs. I pulled the coil packs and on cylinders 2 4, 5, & 6, the bottom of the pack, the blue is now brown and had a very slight oil...

    Started by 9SupraTT4, Yesterday 02:19 PM
    • Replies: 0
    • Views: 22
    Yesterday 02:19 PM Go to last post
  3. Automatic transmission does not engage o/d and reverse

    I just got my auto transmission built on my -93 supra (2jz-gte). I put it back in the car with a Titan 3500 rpm turbine, 2 transmission coolers and a Mishimoto thermostat and filled the transmission fluid to the right level. I warmed the transmission by driving the car and went through the gears...

    Started by FinSupra, 06-23-2017 11:11 AM
    • Replies: 2
    • Views: 93
    Yesterday 11:03 AM Go to last post
  4. Taillights always on?

    So I've had my car apart for the past 6 months and when I went to do the first start up today, everything went well, except that my taillights come on, and stay on as soon as there is battery power. I am assuming that the taillight relay has gone bad. Just odd, because usually they fail in the...

    Started by MKIValex, 06-23-2017 02:31 PM
    • Replies: 2
    • Views: 80
    06-23-2017 10:43 PM Go to last post
  5. Differential Oil change procedure with pics

    Hey guys, I've been on the forums for a few years now and I've been able to find everything I have ever needed by searching. I have been wanting to change the differential oil for some time now so i decided to get wrenching and took some pics to show you all how I did it. I searched but wasn't able...

    Started by jza80king, 04-10-2010 04:08 PM
    • Replies: 14
    • Views: 9,493
    06-23-2017 07:33 AM Go to last post
  6. Question about JDM Fuel Pump Upgrade

    Hello all, My JDM MKIV have, like all JDM 93+ Supras, the N\A Fuel pump that flows 190 LPH. I bought a Denso (US spec) 260 LPH Fuel Pump and installed it in my car. From this moment the car is running horrible. Idle is bad and varies, on giving very sligth throttle the RPM drops to 200 (almost...

    Started by Flames, 10-05-2010 08:13 AM
    • Replies: 21
    • Views: 4,171
    06-22-2017 09:12 AM Go to last post
  7. Trying to determine if PS pumps bad

    I virtually have no powersteering in the car. While I we replacing the short block, the large hose connected to the pump broke and I lose all the fluid. I've sonce replaced the fluid and tried bleeding the pump, several times, with no luck. I don't hear any noise and hesitate to purchase one cause...

    Started by E31, 06-21-2017 12:38 PM
    • Replies: 2
    • Views: 64
    06-22-2017 09:00 AM Go to last post
  8. 3" or 4" downpipe for my setup

    Hey guys I've searched for the past couple days and just haven't really got a straight answer on what size DP/MP I want to run. My setup is a built 3.0, ported head, 272 cams, BW S366 turbo, 840 injectors, 450 Walboro pump and couple other things but that's the main. I'm torn between running...

    Started by EvoDom, 02-26-2016 10:45 AM
    • Replies: 8
    • Views: 507
    06-20-2017 11:33 AM Go to last post
  9. Coolant temp above 200F but dash temp gauge reads normal ....

    I have a ProEFI installed and have been monitoring the coolant temp. The car was running very hot at idle but I found that I needed to burp the coolant. While relieved some of the issue, the coolant is still reading above 200F while idling. The inside gauge, however, never goes above half way. In...

    Started by E31, 03-18-2017 05:48 PM
    2 Pages
    1 2
    • Replies: 37
    • Views: 972
    06-13-2017 02:20 PM Go to last post
  10. Having an issue with brakes

    Hey everyone, just wanted to get some opinions on my current situation. I have an auto 94' gte that's converted to single and recently I've been having brake issues. From what I can tell it sounds like I have an air leak from my TRAC pump or the regulator. I can't seem to find much online besides...

    Started by depasw, 06-03-2017 01:55 PM
    • Replies: 0
    • Views: 68
    06-03-2017 01:55 PM Go to last post
  11. Passenger Door Wire Color Order

    Hey everyone, Was hoping I could get some help. I am having trouble sorting out which wire goes into what hole in the Housing Connector for the passenger side window. When I bought the car the guy was just missing the housing connector but all wires have been installed. The driver side window...

    Started by Cybergreymkiv, 05-22-2017 10:36 PM
    • Replies: 6
    • Views: 161
    05-31-2017 12:48 PM Go to last post
  12. Twin turbo breaks up after pull WOT when you shift into next gear and get back on WOT

    Hey guys, this is my first post. So be nice lol I just got my dream car this past fall and just over the past two weeks have been able to get it out and start driving it. (I live in Wisconsin) It is a 1994 twin turbo supra. Stock twins, aftermarket front mount intercooler, HKS turbo timer, AEM...

    Started by jglenz7x, 05-10-2017 09:29 PM
    • Replies: 24
    • Views: 572
    05-31-2017 12:23 PM Go to last post
  13. Compression test NA

    hi everyone, I'm going to perform a compression test on my NA Sup this coming weekend and was wondering if anyone can tell my how to do this on the NA engine (never done a compression test on my own, but I'm familiar with working on cars ;) ). I know that u should heat up the engine properly...

    Started by xm 1, 05-29-2017 02:25 AM
    • Replies: 2
    • Views: 82
    05-30-2017 02:36 AM Go to last post
  14. 2jz sleeve liners

    After melting some pistons on the dyno last year due to too much compression on pump gas, i was forced to once again re-do my block. I had done Titan billet mains, manley rods, CP 10.0:1 pistons, ported head, gcs S2, BEP s375r haltech ecu, it was a good build but we broke it before we got to high...

    Started by boosted_b20, 05-22-2017 04:22 PM
    • Replies: 2
    • Views: 147
    05-25-2017 06:21 PM Go to last post
  15. Rear end issue

    A little bit of an odd issue. When I shift into low gears on my 6sp the rear end make a loud and jarring bump. I have a lift at home and threw it up there to look and try to reenact the issue. No such luck. So it happens when: -The car is stopped -Clutch is depressed -Transmission is still...

    Started by Riddlekid, 05-25-2017 09:58 AM
    • Replies: 1
    • Views: 62
    05-25-2017 05:33 PM Go to last post
  16. Dakota Digital SGI-5E Speedo Converter in MKIV Supra w/ T56 Magnum swap write up

    I had shared this on some of the FB groups but wanted to make sure it was available here on the forums as well for anyone interested. Put together this video for anyone looking into a T56 swap that had concerns of making the factory speedometer and odometer work, this box will work with a...

    Started by bigb00st, 05-18-2017 07:56 AM
    • Replies: 2
    • Views: 142
    05-25-2017 04:11 AM Go to last post
  17. 2jz Swap And Car Wont Start! Help!!!

    Need some help guys. I have a 93 non turbo 5 speed supra. I jst put in a USDM 2jzgte motor in and kept the w58 5sp tranny. The wiring harness from the 2jzgte is out of a automatic......the car has power but jst wont start,I mean it doest even crank. You turn the key and nothen.....I checked the...

    Started by brandonandboost, 08-26-2009 04:47 PM
    • Replies: 10
    • Views: 3,411
    05-23-2017 04:21 PM Go to last post
  18. SOS no idea what's going on...

    SOS For warning, I'm no mechanic so there might be some things I'm overseeing. Start off I hav3 a 93 NA which is what I'll be talking about. This is gonna be a little long as I'm going into much detail as possible. Alright so the other day I was just on the highway just going along not...

    Started by tmacchrles, 05-20-2017 09:46 PM
    • Replies: 2
    • Views: 145
    05-21-2017 10:26 PM Go to last post
  19. V160 driveshaft ujoint

    When I was putting my engine in the other day I noticed my ujoint on the driveshaft was shot. Apparently no one carries a replacement ujoint ? Who has successfully changed it out and what ujoint did you use? Thanks

    Started by LT1UltraZ, 05-17-2017 05:22 AM
    • Replies: 0
    • Views: 77
    05-17-2017 05:22 AM Go to last post
  20. My homemade hardware chart

    So, as a hardware nut (how punny), I decided to measure every bolt I had run into so far. I spent hundreds (literally) on bags of shiny new zinc coated hardware over the past few yrs. So I never finished this, but I have recently got back into the groove of things, and I will be updating it as I...

    Started by SlackJawOutlaw, 01-26-2017 04:54 PM
    • Replies: 23
    • Views: 912
    05-16-2017 06:27 PM Go to last post
  21. Car alarm randomly goes off after locking car

    Hey guys, so recently ive noticed my car alarm will go off after locking my car. (hell i didnt know i had a alarm till recently lol) It will go for like 1 minute maybe 30 seconds then it will shut off on its own. I only have a key to my car no aftermarket alarm or key fob to set the alarm. I...

    Started by 2jzs13kid, 04-11-2017 08:23 AM
    • Replies: 4
    • Views: 137
    05-14-2017 09:09 AM Go to last post
  22. 1995 Supra SE ABS Questions

    Hey, I have a 95 Supra NA-T with Pro EFI. My ABS light is on and from what I can tell, ABS is not working. I built my own wiring harness and am not using the factory engine harness. When I try to jumper out the diag port under the steering wheel, I don't get any flashing light sequences from my ABS...

    Started by jmcboost, 05-10-2017 11:58 AM
    • Replies: 3
    • Views: 131
    05-14-2017 07:11 AM Go to last post

+ Post New Thread

Forum Information and Options

Thread Display Options

Use this control to limit the display of threads to those newer than the specified time frame.

Allows you to choose the data by which the thread list will be sorted.

Order threads in...

Note: when sorting by date, 'descending order' will show the newest results first.

Icon Legend

Contains unread posts
Contains unread posts
Contains no unread posts
Contains no unread posts
More than 40 replies or 500 views
Hot thread with unread posts
More than 40 replies or 500 views
Hot thread with no unread posts
Closed Thread
Thread is closed
Thread Contains a Message Written By You
You have posted in this thread

Posting Permissions

  • You may post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts