Power Steering Pump pulley making noise

+ Reply to Thread
Results 1 to 14 of 14

Thread: Power Steering Pump pulley making noise

  1. #1
    Great White mysupratoy94's Avatar
    Join Date
    Nov 2003
    Location
    Duarte, CA
    Posts
    402

    Power Steering Pump pulley making noise

    A while back I cleaned up my engine and afterwards notice a sound coming from my engine. At first I thought it was my belts, use some belt dressing but noise remained. I thought it may be the water pump pulley or bearings but to make sure I removed the belt and ran the engine... no sound. After going back and forth found out its my Power Steering pump making the sound. I dont have any leaks coming from it yet, steering works fine so it has to be the bearings.

    If its the bearings do I need to replace the whole pump? I tried spraying some lubricant on the back of the pulley and the sound kind of went away but came back within seconds.
    Last edited by mysupratoy94; 02-10-2009 at 09:29 AM.

  2. Remove Advertisements
    SupraForums.com
    Advertisements
     

  3. #2
    SupraForums Member
    Join Date
    Feb 2003
    Location
    FL currently/MS
    Age
    27
    Posts
    439
    My pump started making an ungodly whirring/whining noise that wasn't to bad at first and at first would go away once the car warmed up. But it got louder and louder, especially when turning.....it ended up being the pump and it wasn't to hard to replace...hour or so.....i got my new pump for $232.98....it list for $336 from toyota

  4. #3
    Kickin'G ASs 24/7 Suprajoey's Avatar
    Join Date
    May 2007
    Location
    Los Angeles
    Age
    25
    Posts
    1,639
    i got mines rebuilt for about 100bucks, but it was also making a whinning nise and was leaking fluid from the reservouir cap...works perfect now...!!
    -I live my life a quarter pounder at a time. And for those 500 calories or more, I'm free. I need FRIES! Two of them. The big ones. Oh, and I need them by tonight. You're lucky the double shot of BBQ sauce didn't blow the seam on your nugget box. There she is, 2 pounds of pure beef. My dad ate it in 9.0 seconds flat.

    -Alright Check It Out, It's Like ThiS, If I Loose, WinneR Takes My HaPpY MeaL, But If I WiN, I Get The CheeseBurGeR AnD The ToY, To Some People Thats MoaR ImportanT...!!

  5. #4
    Great White mysupratoy94's Avatar
    Join Date
    Nov 2003
    Location
    Duarte, CA
    Posts
    402
    Quote Originally Posted by Suprajoey View Post
    i got mines rebuilt for about 100bucks, but it was also making a whinning nise and was leaking fluid from the reservouir cap...works perfect now...!!
    Hey Joey, well mine isnt leaking yet, just making the whining sound. How much did you pay to have it rebuilt and installed?

  6. #5
    SupraForums Member PDuque19's Avatar
    Join Date
    Nov 2007
    Location
    Virginia Beach
    Posts
    344
    have you cleaned out the screen from the inside of the power steering reservoir? when it gets clogged it wont allow enough fluid to get into the pump causing a whining sound.

  7. #6
    Weakness-Beautiful Women IggySupra's Avatar
    Join Date
    Dec 2007
    Location
    Inland E.
    Age
    26
    Posts
    2,189
    ^ this is true. Mine was laking a noise once it was low. It took it a while to go away while warming up. Just make sure its full of fluid or it will do it. I filled mine and it went away.

  8. #7
    Great White mysupratoy94's Avatar
    Join Date
    Nov 2003
    Location
    Duarte, CA
    Posts
    402
    Thank you everyone for your input, really appreciate it. Everyone I took it too kept saying it was either the pulley or bearing inside the PS pump. Fluids were fine, no leaks, no sounds when turning wheel... so all that made me doubt it was the pump. anyways, i went to autozone, bought a cheap drive belt and guess what, that was the fix. The sound it was making before was a grinding noise, something you would hear when the bearings are grinding or dry, so i never thought it would be the belt. The OEM belt I had was only about 20,000 miles old. Before you go spending big bucks, always check the drive belt for any weird noises!

  9. #8
    Found E85 NOT in NJ! twinturbosupra94's Avatar
    Join Date
    Jul 2004
    Location
    Wayne, NJ
    Age
    26
    Posts
    5,248
    Whining noise = pump starting to take a shit.

    I THOUGHT mine was going bad, but it turned out that I forgot to install 2 bolts holding the pump together (pressure was escaping).

  10. #9
    SupraForums Member bkydsupra935's Avatar
    Join Date
    Feb 2008
    Location
    Georgia
    Posts
    335
    wow. this info is good knowing that my pump is both starting to leak and splatter fluid and make the whining noise. lol..

  11. #10
    Great White mysupratoy94's Avatar
    Join Date
    Nov 2003
    Location
    Duarte, CA
    Posts
    402
    Quote Originally Posted by bkydsupra935 View Post
    wow. this info is good knowing that my pump is both starting to leak and splatter fluid and make the whining noise. lol..

    That definietly sounds like a bad PS pump. Mine wasnt leaking, just making a horrible sound. Check the forum for used pumps... a new one will run you about 400.00 bucks. You can have it rebuilt for like under 150.00 or buy one from a forum member for under 100.00. I almost bought one from a member but im good now.

  12. #11
    SupraForums Member bkydsupra935's Avatar
    Join Date
    Feb 2008
    Location
    Georgia
    Posts
    335
    lol. yeah im in the process right now between to members. trying to get the best used price lol..

  13. #12

    Join Date
    Nov 2007
    Location
    There
    Posts
    28
    hey guys, i haven't the same problems. it would go away after like 20-30 mins of driving, but it's still annoying to me.. my shop which specializes in performance car like the supras said it's the common problem on the power steering pump, and the only way is to replace it. I can get it from the dealer, but does anyone kno, or have a guide to replace the pump? If it's something easy, i dont want to pay the shop to do it, and my shop is 2 hr drive away..

  14. #13
    SupraForums Member
    Join Date
    Feb 2003
    Location
    FL currently/MS
    Age
    27
    Posts
    439
    its pretty easy. I did mine in the driveway in an hour or so.

  15. #14
    Great White mysupratoy94's Avatar
    Join Date
    Nov 2003
    Location
    Duarte, CA
    Posts
    402
    Quote Originally Posted by 93na View Post
    its pretty easy. I did mine in the driveway in an hour or so.
    Have a write up on it?

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts