AC issue

+ Reply to Thread
Page 1 of 2 1 2 LastLast
Results 1 to 25 of 30

Thread: AC issue

  1. #1
    SupraForums Member whitetiger777's Avatar
    Join Date
    Mar 2006
    Location
    Encino Ca
    Age
    38
    Posts
    835

    AC issue

    So, haven't had this issue before with AC. When I turn on the AC it blow cold and will do so for an amount of time. It's different every time. Then it goes warm. It doesn't matter if I'm stuck in traffic or doing 70 mph. Given that the air will go warm even if the car is moving at speed, im guessing it's not the compressor but am open to opinions

  2. Remove Advertisements
    SupraForums.com
    Advertisements
     

  3. #2
    SupraForums Member supralover93's Avatar
    Join Date
    Mar 2002
    Location
    Sacramento, ca
    Age
    34
    Posts
    4,560
    expansion valve is sticking?
    §§
    93 turbo targa
    auto
    BPU

  4. #3
    SupraForums Member whitetiger777's Avatar
    Join Date
    Mar 2006
    Location
    Encino Ca
    Age
    38
    Posts
    835
    How does once check that?

  5. Remove Advertisements
    SupraForums.com
    Advertisements
     

  6. #4
    SupraForums Member supralover93's Avatar
    Join Date
    Mar 2002
    Location
    Sacramento, ca
    Age
    34
    Posts
    4,560
    thats something an AC tech would have to check with a set of gauges. chances are you will have to take it in to get proper diag work done. even if the expansion valve is bad, you would have to evac. the system before making the repair (which is NEVER fun).

  7. #5
    SupraForums Member
    Join Date
    Apr 2018
    Location
    Tampa
    Posts
    123
    How cold is it when it first works? Ice cold or just cool. AC's are funny in that they can be just a bit low and not work well at all.

    You can buy a cheapy gauge that has both high and low side fitting where you can check pressures on each side. You should be able to use a quick reference guide to estimate where your pressures should for the ambient temp with the compressor running (it will be obvious if it isn't as pressure will be the same).

    When I first got my Supra a year ago after a month my AC started going from cool to ambient while driving. My high side pressure I believe was around 150 psi. I added about a 1/2 can of R134A and the pressure came up to about 200ish (was a 90+ degree day) and now is ice cold. Been that way for about 9 months.

    You could alsways buy a small can and just add in a bit (2 oz) of refrigerant and see if that helps. If you are low that little bit of refrigerant would make an exponential difference.

  8. #6
    I Can Has EBT? shak's Avatar
    Join Date
    Apr 2004
    Location
    Jax FL
    Posts
    3,216
    x2 on expansion valve. I had mine go out years ago, but I remember the same symptoms you are describing.

    thread on how to replace, but you will need someone to recycle freon for you, and cycle it back tot he system when you are done.
    https://www.supraforums.com/forum/sh...xpansion-Valve
    Last edited by shak; 03-13-2019 at 06:49 AM.

  9. #7
    SupraForums Member whitetiger777's Avatar
    Join Date
    Mar 2006
    Location
    Encino Ca
    Age
    38
    Posts
    835
    Doesn't seem that hard aside from vac'ing the system

  10. #8
    SupraForums Member
    Join Date
    Jan 2019
    Location
    Chattanooga, TN
    Posts
    68
    i would try adding a can of 134 first... to see if it fixed it.
    if it does,... then you have a slow leak.

    but im with the other guys... looking like an expansion valve.

  11. #9
    SupraForums Member whitetiger777's Avatar
    Join Date
    Mar 2006
    Location
    Encino Ca
    Age
    38
    Posts
    835
    Will check the pressure this weekend

  12. #10
    SupraForums Member
    Join Date
    Aug 2010
    Location
    Norfolk
    Posts
    142
    I would not recommend adding refrigerant to the system. If there isn't a leak and the correct amount of R134-A is still in the system, an over-pressure situation could occur causing damage to the compressor. If the compressor goes, then you can also say goodbye to the condenser and the lines. I recommend evacuating the system, refilling with 24.5 oz of R-134A and UV dye, then performing a diagnosis. Part of the diagnostic process prior to recharging involves pulling a vacuum on the system for 24 hours to see if it holds. This will help narrow down the presence of a leak. Recharge with R-134 that does not have any sort of fix-a-leak or sealant in it. Run the system for an hour then check for leaks using a UV light. Remember to look under the dash, around component input/outputs, and at the recharge/discharge valves. Verify the correct pressure indications on the H/L side using the gauges and the FSM. Without using the process described above, you are guessing, which can be an expensive gamble. If you are willing to gamble on a guess, it does sound like the expansion valve went south. You can't hurt anything by replacing it and the corresponding O-rings, and recharging with R-134 and the UV dye. The benefit is, you will have eliminated a common culprit, and made future troubleshooting easier. I'd also recommend replacing the receiver/drier and it's corresponding O-rings when you open the system. You will likely have repaired your issue using this process. If not, you are way farther along in the troubleshooting process and already have to two most common AC wear parts replacement enroute to the repair that fixes it. Good luck, and PM me with your email if you would like any pictures. I did this entire process last year when I repaired a leak in the AC hard lines. Thanks! -Tony

  13. #11
    SupraForums Member
    Join Date
    Apr 2015
    Location
    MS
    Posts
    69
    For what its worth, I chased down a similar issue. After going through steps like listed above, I still had the problem. What I ended up finding with my system, is the wiring harness that connects to the controls was full of shorts. A new plug and a wiring harness repair kit solved my issue.

  14. #12
    SupraForums Member whitetiger777's Avatar
    Join Date
    Mar 2006
    Location
    Encino Ca
    Age
    38
    Posts
    835
    I was starting to wonder if it was an electrical thing

  15. #13
    SupraForums Member
    Join Date
    Aug 2010
    Location
    Norfolk
    Posts
    142
    MarkH brings up a very good point. The stuff I mentioned only addresses the refrigerant part of the system. There is also the mechanical and electrical part, each requiring an investigation. A good check of all the components will help you save some $ and time in the end. Good luck and let us know how it goes!

  16. #14
    SupraForums Member whitetiger777's Avatar
    Join Date
    Mar 2006
    Location
    Encino Ca
    Age
    38
    Posts
    835
    Think I might just take it to a ac place to have it checked

  17. #15
    SupraForums Member whitetiger777's Avatar
    Join Date
    Mar 2006
    Location
    Encino Ca
    Age
    38
    Posts
    835
    Took the car to a ac shop and the pressure on the high side was the same as the low side, so it must be the expansions valve.

    Wish there was a video or picture step by step for this. System is already vac'ed out.

  18. #16
    SupraForums Member
    Join Date
    Aug 2010
    Location
    Norfolk
    Posts
    142
    Here's a general outline:
    1. In engine compartment, remove 10mm bolt securing a/c lines to firewall.
    2. Drop glove box, and supporting brackets behind it.
    3. In accordance with FSM, disconnect harnesses, plugs, and remove fasteners that secure the evaporator core to heater box.
    4. Manuever evaporator core down and out of heater box.
    5. Unbolt expansion valve from evaporator core.
    6. Replace all o-rings on opened a/c lines. Should be two for the a/c lines in the engine compartment, and four on the expansion valve. Lubricate the o-rings with some u/v dye.
    7. Clean evaporator core and condensation pan of debris, leaves, 20 years worth of crud, etc.
    8. Reinstall is reverse of previous. If required, add compressor oil per FSM. You might not need to when just replacing the expansion valve, but chaning out condenser, drier, compressor, and other large components require that you add a certain amount to replenish what's lost.
    9. Recommend (required actually) replacing receiver/drier and associated o-rings at this time. It's 20 years old+, and the desiccant is no longer effective. The system has been opened and that drier can't absorb moisture it's now exposed to. Your compressor will in the form of failure. Be sure to add the right amount of compressor oil per the TSM.
    10. Recharge with 24.5 oz of R-134a and and couple ounces of u/v dye.

    A note on the compressor oil.. ND-8 is what is called for but good luck finding it in small quantities. You can find an equivalent at parts stores; but it's synthetic unlike good ole ND-8.

    If you'd like pictures, I can email you a few that might help with disassembly. Just PM me. Good luck! -Tony

  19. #17
    SupraForums Member
    Join Date
    Feb 2002
    Location
    Ft. Worth Texas
    Posts
    2,183
    Vtony 100% right! Although, I prefer not putting any dye in. I've seen this on a few MKIVs. New expansion valve, along with all mentioned above, solves the issue.

    Don't see it mentioned but is implied, vacuum the system for 45 minutes minimum through gauges, close off high and low side valves and watch for 10 minutes for loss of vacuum. Hook a can to the center line and unthread at the gauge side and allow a little r134 gas to purge the line of any air (moisture). I always just turn the 1st can over and allow the liquid into the vacuumed system before starting the engine. After a couple of minutes I'll start it up and turn on the a/c, let it pull down as low as it'll go on the low side and close the valve and hook up another can. I've never had an issue with turning the can over and slowly letting in liquid r134. I just barely crack the low side valve just enough so the needle starts to jump slightly and let it dribble in for 5 minutes or so. It's always takes forever letting it boil off from the can.

    ND-8 is equivalent to PAG 46.

    compressor-oil-1_614x307.jpg
    Last edited by Kurt; 04-21-2019 at 09:33 PM.
    1997 GE VVTi 6spd

  20. #18
    SupraForums Member whitetiger777's Avatar
    Join Date
    Mar 2006
    Location
    Encino Ca
    Age
    38
    Posts
    835
    I'll probably go with the pag oil since it's easier to find

    I'm definately interested in those pics that were offered

  21. #19
    SupraForums Member
    Join Date
    Aug 2010
    Location
    Norfolk
    Posts
    142
    Kurt,

    Yes, forgot to add that very critical piece. I vacuumed it for 2 hours, then held the vacuum for 24 hours, without leaks. Way overkill, but I had the time. I used the directions on the gauge set to purge the air in the filler line, but I like your approach better. OP, I can shoot you the pics via email.

  22. #20
    SupraForums Member whitetiger777's Avatar
    Join Date
    Mar 2006
    Location
    Encino Ca
    Age
    38
    Posts
    835
    How did you all get at the bolts in the engine bay? Not only is it near impossible to get a wrench there, I'm afraid if I do I wont be able to get them back in.

  23. #21
    SupraForums Member whitetiger777's Avatar
    Join Date
    Mar 2006
    Location
    Encino Ca
    Age
    38
    Posts
    835
    Ok got the bolts out, but now how do I get the core out and the lines off?

  24. #22
    SupraForums Member SupraPVB's Avatar
    Join Date
    Jan 2008
    Location
    Jacksonville, FL
    Posts
    992
    If it’s already determined bad expansion valve - disregard

    I had a bad climate control unit that would work fine then blow hot air at random times., 94 Supra. I borrowed a friends climate control for a few days and solved issue. I put in the bad one again and did same thing again blowing cold then out the blue would blow hot air whenever it felt like it

    Stu Hagen used to repair climate controls for folks back in the day. Could ask...or

    Borrow a local Supra owners and see if it resolves... that’s what I did
    Last edited by SupraPVB; 05-11-2019 at 05:14 AM.

  25. #23
    I'm not serious
    Administrator
    FasTTurbo's Avatar
    Join Date
    Oct 2001
    Location
    CT
    Age
    36
    Posts
    7,833
    Great thread, also if the guts go bad on your super expensive usdm climate unit the rhd jdm climate guts are the same and usually 1/3rd the price used.
    pink painted powerfucked cat's ass - Jeff (Wreckless) 2018

    Find me on IG: @sick_6
    supraforums on IG:@SUPRAFORUMSPICS
    Looking for turbo auto or 6spd Supras!
    93 Alpine Auto
    94 Alpine 6spd
    94 RR 6spd
    97 Alpine AT
    98 QS AT
    ①③⑤
    ├┼┼┐
    ②④⑥R

  26. #24
    SupraForums Member supralover93's Avatar
    Join Date
    Mar 2002
    Location
    Sacramento, ca
    Age
    34
    Posts
    4,560
    The AC place that charges your system can add the correct oil for you. Just empty out our old condenser and measure what comes out.

  27. #25
    SupraForums Member whitetiger777's Avatar
    Join Date
    Mar 2006
    Location
    Encino Ca
    Age
    38
    Posts
    835
    Got it all swapped out. I did a full photo write up on the Facebook pages for other people who need to do this. I'm going to do the condensor today. Then if that doesn't fix the issue I get a hold of stu. However the ac shop said it was more than likely the expansion valve since the psi was the same on high and low side.

+ Reply to Thread
Page 1 of 2 1 2 LastLast

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

List your Car(s)

Where you live

Please select your insurance company (Optional)

Your Supra's Vehichle Identification Number (Not visible to the public)

Log-in

Similar Threads

  1. WTB MK4 AC Amplifier and AC ducting system!!!!!!!!!
    By SuspectSupra in forum Florida For Sale/Wanted
    Replies: 1
    Last Post: 06-13-2011, 09:34 PM
  2. AC or no AC
    By boltz in forum Canadian Forum
    Replies: 14
    Last Post: 12-18-2005, 07:28 AM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •