Car suddenly won’t start?! (Video) inside

+ Reply to Thread
Results 1 to 13 of 13

Thread: Car suddenly won’t start?! (Video) inside

  1. #1
    MrChewsAsianBeaver mk4playy's Avatar
    Join Date
    Aug 2003
    Location
    chicago
    Age
    37
    Posts
    491

    Car suddenly won’t start?! (Video) inside



    I’m stumped

  2. Remove Advertisements
    SupraForums.com
    Advertisements
     

  3. #2
    SupraForums Member
    Join Date
    Sep 2009
    Location
    CT
    Posts
    554
    EFI fuses(s) ?

  4. #3
    MrChewsAsianBeaver mk4playy's Avatar
    Join Date
    Aug 2003
    Location
    chicago
    Age
    37
    Posts
    491
    Which fuse is it? Thanks for your help

  5. Remove Advertisements
    SupraForums.com
    Advertisements
     

  6. #4
    SupraForums Member
    Join Date
    Sep 2009
    Location
    CT
    Posts
    554
    Look at underside of fuse-box cover in engine compartment. There are two, EFI1 and EFI2.

  7. #5
    MrChewsAsianBeaver mk4playy's Avatar
    Join Date
    Aug 2003
    Location
    chicago
    Age
    37
    Posts
    491
    I took efi2 out and replace it with the fog fuse just to test it. Still nothing. I change the fuel pump out as well. Could a clogged fuel filter cause this? I dunno

  8. #6
    SupraForums Member
    Join Date
    Jan 2019
    Location
    Chattanooga, TN
    Posts
    60
    are the plugs firing?

    after a few cranks, if you pull the plugs are they covered in fuel?

  9. #7
    MrChewsAsianBeaver mk4playy's Avatar
    Join Date
    Aug 2003
    Location
    chicago
    Age
    37
    Posts
    491
    I’ll check that next

  10. #8
    SF Contributing Member bitshftr's Avatar
    Join Date
    Jan 2009
    Location
    Raleigh, NC
    Age
    51
    Posts
    2,903
    You left something unplugged maybe? What was the last thing you did to the car?
    1995 Supra NA, Baltic Blue, targa, TRD LSD, Recaro Sport seats, Cusco carbon fiber front/rear strut tower bars, 97+ front turns
    Passport hardwired, w/ amped remote speakers in seat harness slots
    Hidden/hardwired garage door opener w/ custom Supra dash button


    1995 Supra TT, BPU+, Baltic Blue, targa, TRD front/Cusco rear strut tower bars, 98 headlights w/ 6k HIDs, 97+ front turns, BNR turbos, Tial BOV, HKS Super Drager exhaust, SSR Professor SP1 wheels, Racelogic TC, VPC/GCC
    Passport hardwired
    Hidden/hardwired garage door opener w/ custom Supra dash button
    Subtle white LED dash backlights

  11. #9
    MrChewsAsianBeaver mk4playy's Avatar
    Join Date
    Aug 2003
    Location
    chicago
    Age
    37
    Posts
    491
    Nothing unplugged.. was fine one day. Then went to start it the next morning and it started then started choking out then turned off

  12. #10
    SupraForums Member mkivsoopratt's Avatar
    Join Date
    Jun 2010
    Location
    South Florida
    Posts
    791
    Spray some starting fluid in and see what happens. If it starts with the fluid you have a fuel issue
    “Lag is foreplay” - Biologist

    1995 Toyota Supra Single Turbo 6 Speed Hardtop VVTI

    1991 Nissan Skyline R32 GTS-T 5 speed

    2017 Toyota Tacoma V6

  13. #11
    SupraForums Member supman's Avatar
    Join Date
    Jan 2010
    Location
    renton
    Posts
    142
    Check your fuel pressure.

  14. #12
    SupraForums Member supman's Avatar
    Join Date
    Jan 2010
    Location
    renton
    Posts
    142
    Open data link connect 1 located in the engine compartment above and next to your turbo downpipe (small black rectangle box) using a electrical wire or SST, connect terminals B+ and FP, turn the ignition switch On but do not start you should able to hear the fuel pump running, if not then your fuel pump has no power.

  15. #13
    SupraForums Member
    Join Date
    Jul 2008
    Location
    South Florida
    Age
    31
    Posts
    326
    Sounds like ECU or fuel ECU to me.

+ Reply to Thread

Quick Reply Quick Reply

Register Now

Please enter the name by which you would like to log-in and be known on this site.

Please enter a password for your user account. Note that passwords are case-sensitive.

Please enter a valid email address for yourself.

List your Car(s)

Where you live

Please select your insurance company (Optional)

Your Supra's Vehichle Identification Number (Not visible to the public)

Log-in

Similar Threads

  1. 94 turbo suddenly wont start
    By CheckElbow in forum MKIV (1993-1998)
    Replies: 12
    Last Post: 01-08-2019, 04:32 PM
  2. Driving and lost power suddenly... engine won't fire now!
    By DanielSon in forum Naturally Aspirated Technical
    Replies: 5
    Last Post: 12-30-2015, 08:45 AM
  3. Car won't start. Turns on but won't turn over.
    By JCFsupra in forum 1JZ/2JZ Swap
    Replies: 3
    Last Post: 05-04-2011, 07:36 PM
  4. Suddenly, car will nto start.
    By Altezza576 in forum MKIV Technical
    Replies: 3
    Last Post: 01-02-2011, 01:41 PM
  5. Car suddenly won't start.. Hope AEM isn't bad? No clue..
    By mac_05evo in forum MKIV (1993-1998)
    Replies: 88
    Last Post: 07-31-2009, 10:31 PM

Posting Permissions

  • You may not post new threads
  • You may post replies
  • You may not post attachments
  • You may not edit your posts
  •