Supra Forums banner

1 - 20 of 27 Posts

·
Registered
Joined
·
234 Posts
Discussion Starter #1
Ran last Thursday in Vegas 10.35 @ 137mph against a Busa in the Semi Finals. Heres what the car have.

Virtual Works Turbo System with 74mm
Virtual Works Intake Manifold
AEM EMS
1000 CC Injectors
HKS Ignition
30 PSI on 100 octane
26X11.5X16 ET Streets
Stock Block, Stock Head, Stock CAMS

Tires were pretty worn out, top end got alittle crazy, next time out plan on new set of tires and re adjust the suspension and try for a 9. If I can find someone to host, I have the run on Mpeg.

Special thanks to Tony Orta @ Final Stage for helping me getting the car together all week, and Ben @ Virtual Works for helping me tune that night.
 

·
Registered
Joined
·
234 Posts
Discussion Starter #2
For some reason, forum wont' let me post the time slip from jpeg. Ill try from another computer later.
 

·
Registered
Joined
·
2,712 Posts

·
Registered
Joined
·
234 Posts
Discussion Starter #8
Does the pix have to be in any specific file name? no matter what I do it won't let me upload. Or someone else wanan try and Ill email the slip.
 

·
Registered
Joined
·
234 Posts
Discussion Starter #15
VIRTUALWORKS said:
Congrats Jack, Damn no love for building the car :)

Dana,
Virtual Works
8.89 @ 155
You had plenty of love the first time when I ran 10.60's, besdies I didn't see you next to me at staging lanes that nite :p j/k.
 

·
Registered
Joined
·
234 Posts
Discussion Starter #18
Red C5 said:
Nice 60' too. I can host the vid if you need it still.
My software is all screw up, the orginal video is 50 meg, trying to shrink it, when i do the actual video / audio is not in scyn and cuts off. Ill try it again later and Ill email a mpeg 1 version to ya if you can host it. Thanks again.
 

·
Yeeehaaa, Jester's dead!
Joined
·
682 Posts
Way to go. I hope to be where you're at this year with my new setup. How much power do you think your car was laying down when you ran? Also what kinda tires?
 
1 - 20 of 27 Posts
Top