Supra Forums banner

1 - 11 of 11 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1 (Edited)
On street tires i did
12.53 @ 121 with 2.16 60' spinning badly 19psi

And on DR's

13.0 @115 @ 19psi Did that Twice
12.3 @119 with 2.10 60' with 21PSI


The car feels like it lost power, but I am boosting no problem. What could it be? Someone said that my turbo could be going bad. Any ideas?
 
R

·
Guest
Joined
·
0 Posts
Discussion Starter #4
is it possiable that your just not used to driving the car with the DR's
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #5
redmkivtt said:
is it possiable that your just not used to driving the car with the DR's
No, my 60' was 2.10 and I didn't spin in 2nd. Where I had to let off the gas twice in 2nd gear on my street tires, basically everything was better on DR's but i ran much slower times.
 

·
Registered
Joined
·
770 Posts
Those are some low traps on your DR runs. What were your 60" times? Did you put a 1 where the 2 went? What drag radials were you running?
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #7
spooler21 said:
Those are some low traps on your DR runs. What were your 60" times? Did you put a 1 where the 2 went? What drag radials were you running?
YEs I did put 1 instead of 2. Nitto 17's.
 

·
Registered
Joined
·
770 Posts
Something obviously happened with your car. I was running on street tires and ran a best of a [email protected] and i was getting an average of 2.2 and 2.3 60' times. I bought nitto 275/40/17 555r's and went again and hit [email protected] with a 1.9 60'. My problem is the shitty track down here but your traps shouldnt get lower with better traction it should get higher. These runs were at 20psi throught a t60-1 and cast mani.
 

·
Lets go Nets
Joined
·
2,956 Posts
nice times, paul, whos dr's did u use?

Brett
 

·
Lets go Nets
Joined
·
2,956 Posts
hey 12.3 is your best time ever, be happy, im saying you take your car to a dyno and see whats up. idk who rob is so whatever.

Brett
 
1 - 11 of 11 Posts
Top