Supra Forums banner
1 - 17 of 17 Posts

·
Registered
Joined
·
1,340 Posts
Discussion Starter · #1 ·
hi guys. i know my times suck ass. this supra is nothing like my camaro when it comes to drag racing. i got a 2.460ft on this run. this was also on street tires. will BFG's take care of my traction problem and how the hell do you launch a manual?

thanks in advance.
 

·
Newbie
Joined
·
11,217 Posts
DR's will def improve traction. It'll prob lower 1/10th of a sec or 2. I just rev up to about 3500 and hold it there. Any higher and my shit busts.
 

·
Registered
Joined
·
9,812 Posts
You definately need drag radials, and probably a better clutch. If you can get your 60 ft in the 1.6-1.7 range you will be busting out mid to high 11's all day.

Jason
 

·
Registered
Joined
·
1,340 Posts
Discussion Starter · #5 ·
thanks fellas. i'm debating on either BFG's or the MT ET streets.

i have a spec stage 3 clutch already installed. do i need better than this??
 

·
Registered
Joined
·
3,688 Posts
Definitely go with ET streets. Remember to slip the clutch alittle out of the hole on these cars. Can't just drop the clutch like i could in my previous z28 and go.
 

·
Registered
Joined
·
1,340 Posts
Discussion Starter · #9 ·
thanks guys... keep the ideas coming. this supra is much harder to launch than my camaro ever was.

any yes,, this car is not stock. this is the really sad part. i ran a 9.2 in the 1.8 mile. the car broke loose and i had to let off then get on it again.
 

·
Registered
Joined
·
3,688 Posts
I'm betting it broke loose at teh 2nd to third shift. It did that on mine too, I'm also guessing you're in sequential mode. When i converted to TTC it was easier to drive down the track as the power came in much smoother.
 

·
Registered
Joined
·
1,340 Posts
Discussion Starter · #12 ·
thanks.. right now i'm running a SP61GT and i was only boosting 20psi. i wanna take it to 26psi but i can 't hook for crap.
 

·
Registered
Joined
·
3,688 Posts
Hmmm, 117 is pretty low for a SP61GT running 20psi. I would make sure everything is running right with the car and possibly throw in a new set of plugs and reset the ECU. Did you do a compression check on this car yet?
 

·
Registered
Joined
·
1,340 Posts
Discussion Starter · #14 ·
AlpineTT said:
Hmmm, 117 is pretty low for a SP61GT running 20psi. I would make sure everything is running right with the car and possibly throw in a new set of plugs and reset the ECU. Did you do a compression check on this car yet?

lol.. sorry i forgot one MAJOR detail... it's a 7m-gte. i have a mk3 supra. (runs and hides in a corner)
 

·
Registered
Joined
·
9,812 Posts
Damn dude, you got us all!!!! I guess we all know what ASSUME does now dont we? You should still be able to run 11's with that setup. You will just need to practice alot to get the 60 down.

Jason
 

·
DO WORK!!
Joined
·
2,275 Posts
try slipping the clutch... I got my 60' down to a 1.9 with very little tire spin. I ran a 13.3 at 105mph. So yeah get that 60 foot down and you will be in the low to mid 12's.
 

·
SUPRAS FOR LIFE
Joined
·
4,186 Posts
rev it up to about 3500rpm and.....all thru first gear slip the clutch and on second hit the hammer...u really dont need dr's to get better et's.....
 
1 - 17 of 17 Posts
Top