Supra Forums banner

181 - 200 of 222 Posts

·
MKIV owner since 1998
Joined
·
1,523 Posts
I also want to know with the Tundra alternator is a different belt required and what other fuses need to be changed, if any?
 

·
Registered
Joined
·
114 Posts
150 amp is 27060-0F050

I accidentally bought two for 90 shipped from "alltoyotalexusparts " So this one is still for sale if anyone is looking. I found another one here. The going rate at local junkyard seems to be 80-100 bucks for one these.

Thanks for that.

I just scored a 130amp alternator from a 2008 tundra for a whopping $47 shipped on there. :)

I'll post up after I get it installed.
 

·
Follow the white rabbit
Joined
·
1,653 Posts
I cant tell you the part number since its on the car and I never checked. I just looked for a tundra alternator on ebay that was advertised as the 130amp. this was the listing name 03 04 05 06 TOYOTA TUNDRA ALTERNATOR 8 CYL 130 AMP. The listing expired so I dont have more info on that. I used the stock accessory belt and I am still on the same fuse. No need to swap fuses unless I actually start pulling that kind of amperage from the alternator. I got mainly for the idle power bump since I like my cars to idle around 6-800 rpm (street manners).
 

·
Registered
Joined
·
197 Posts
Just did this swap due to low charging voltage on my stock 90 amp alt (voltage was around 12.9 to 13.0). I went with the 150 amp alt and I'm only getting 13.5 volts most of the time. I ran a secondary 4 gauge wire from the alt directly to the battery (in the trunk) and it did not help. :( Is 13.5 normal? I thought it was supposed to always be around 14.5 or so. Ive grounded the engine and the battery pretty well also. Any other advice on wiring or ideas that I could do to troubleshoot would be greatly appreciated! I have FAL dual fans and dual bosch 044's that for sure pull some power.
 

·
that twin 2jz guy
Joined
·
2,595 Posts
i also did a 4.7L 130amp alternator and i never saw higher than 13.8~13.9. another buddy did the same swap and hes around 13.9. never into 14.s.. i did some more test at work on some 4.7l alternators.. and i am a 0 guage wire.. and same thing.. so am gonna try ohio generators with a single wire setup and see what develops.
 

·
Registered
Joined
·
195 Posts
Is that 13.9 with lights, ac, fans and stuff on? Or with that stuff off? I have the stock alternator and it takes a dive when the fans kick on and im running lights and ac.
 

·
Registered
Joined
·
197 Posts
OK, good info! Thanks for sharing. I have the optima red top battery and wonder if that has something to do with it. What batteries do you guys have? I guess my main concern is that at 13.9 , is my spark going to be any different then at 14.5 and will it affect anything else electronic? I'm getting ready for the dyno and want to make sure everything is runnig at its full potential. :)
 

·
Registered
Joined
·
989 Posts

·
Registered
Joined
·
213 Posts
hey guys, just scrolled through all 8 pages of the thread. Looked in my area for a 130amp, but only found a 150amp from a tundra for $50. My battery is relocated in the bank with 0 gauge wire. I haven't messed with any of the other alternator wire/fuse/etc. Will the 150amp work, or would i have to change the wiring?
 

·
Question to suit.
Joined
·
3,562 Posts
Just finished installing a 150 amp. Tomorrow will be the test, to see if it makes a difference.

You shouldn't have to change anything, except the S, IG, and L wires. I also added a 4ga wire from alt.to battery.

The positive post on the 150a alternator, is smaller diameter versus the 1JZ alternator. Weird to me, as it doesn't match the output ratings.
 

·
Raising the BAR
Joined
·
3,324 Posts
Just finished installing a 150 amp. Tomorrow will be the test, to see if it makes a difference.

You shouldn't have to change anything, except the S, IG, and L wires. I also added a 4ga wire from alt.to battery.

The positive post on the 150a alternator, is smaller diameter versus the 1JZ alternator. Weird to me, as it doesn't match the output ratings.
I think you'll be happy. I just installed my 200amp alt a couple weeks ago and I couldn't be happier.
 

·
Question to suit.
Joined
·
3,562 Posts
I noticed a difference right away. Spark is consistent, no more dimming!
 

·
Registered
Joined
·
806 Posts

·
Registered
Joined
·
806 Posts
I think you'll be happy. I just installed my 200amp alt a couple weeks ago and I couldn't be happier.
where did you get this from??
 

·
Registered
Joined
·
806 Posts
really, none??
 
181 - 200 of 222 Posts
About this Discussion
221 Replies
71 Participants
daviddi92
Supra Forums
Supra Forums is the largest online Toyota Supra MKI, MKII, MKIII, MKIV and MKV owner's club community. Discuss DIY, modifications, and upgrades.
Full Forum Listing
Top