Supra Forums banner

1 - 20 of 103 Posts

·
Registered
Joined
·
501 Posts
Discussion Starter #1 (Edited)
I wanted to share some wiring info on those who wanted the "fun" with a VVTi harness.

Added pinouts for the JZX100/110 post #33/35

I did not find much help with the harness from the chaser's, so seperated the harness and found the wires locations from the body side to the engine.

I will include some diagrams from the ecu as well. The ecu has the same connectors as the non-vvti 1jz. The chaser harness does not include two of the ecu connectors there is a list of ecu's that was made (not tried by me) but may be helpfull as well.

 

·
Registered
Joined
·
501 Posts
Discussion Starter #10
I am using this info I found to try to wire this up into my Sc3 without the (easy way) help of Dr. Tweak. It seems to be a bit of work but with the info available on the USA market car it is going in I should be just fine.

My only real issue's would be leaving the TRAC stuff out, is the ecu going to care? and finding the missing maf (95-97 sc/ls400 pin #22250-50060) and igniter (98+ VVTi 2jzge pin #89621-30020)
I found car-part.com helpfull

I hope someone finds this helpfull.
 

·
Registered
Joined
·
501 Posts
Discussion Starter #11
I went a but further and wanted to show what the missing connectors in the ecu are ( H & G ), With the help of Jason Purcell~ and his online info here are some more pics with diagrams for the ecu.





 

·
Registered
Joined
·
501 Posts
Discussion Starter #12 (Edited)
Video showing how to run the swap without installing it into the car. Click pic for video.

*!!! If you do not take care to secure the engine while it is running outside a car it WILL tip/ flip over!!!* I used a eng hoist as well as had the engine secured to a 4 point engine stand. It was not shown but I had the fuel system setup with a special system and the return line was sealed after the fpr. It does not run too great with the afm attached to the tbi due to the iacv routed back at the turbo inlet. Dont forget to plug off the brake booster hose as well as any other manifold vac lines. It is a bit on the noisy side as well as creates a good bit of fumes, I would advise doing this in a well ventilated area.

 

·
Registered
Joined
·
501 Posts
Discussion Starter #17
Update.

Have had the motor in for a while now and raced it at a few drift events, great power and crazy low end tq. (stock)

Now the bad I have found since the swap.

The tps was found to be broken (dammit!) and for those who want to find one here in the USA -good luck!
* Interesting bit if diag btw~ The motor with the bad tps ran great cold, when it warmed up is another story. You would know there is a problem when it got closer to operating temp. Idles fine, motor near dies when you touch the gas like an unplugged afm. Hope that helps. There is not a USA toyota part that will work with the factory tps that came on the vvti 1jz. I have looked and found the number 89452‑24020 for the factory part but it is not available. There is a kia/hyundai? in 99 that uses the ga16 motor that I have read uses a similiar/same tps, don't bother. It is easy to find another non-trac tbi. I tried to just swap the guts into the vvti but found just bolting on the other 1j tbi to work best. I had to rewire the tps from 3 wire connector to the 4 wire tps. Easy when you look at a USA turbo MK4 wiring diagram, you will not use one of the pins in the tps. Don't forget to set the voltage on the tps, follow the tps adjustments for the USA turbo MK4. You might need to play with the idle a bit, that is if your tach works....
Also.
I had some fuel issues I wanted to share with SF. I found my vent line under my car managed to get a bit smashed up (likely from the many high speed entry's right into the dirt..) the fuel pump was overheating and not liking it (higher temps and pressure). I have also noticed the heat soak under the hood is going to be a problem (working on that as well).

The vvti 1j did not like the plugs I would normally run in other jz's, I found the (OE) NGK BKR6EK twin electrode works great even with higher boost levels. Replacing the wires and boots for the coils is a great idea at the same time.

I got a r154 with the chaser swap but still am running the w58 without any problems as of now, MK4 sidemount air cooler is a good match~ I did add a cooling fan to the front side (sport bike rad fan).
 

·
Registered
Joined
·
187 Posts
wow - I'm really impressed by the level of details and all of the info shared (I may have to download it all to keep!). Can you scan your typed-up info to get the engine running without physically putting it in the car?

Also as an fyi there are 2 types of 1jzgte vvti - The one you got, out of the chaser jzx100 and then the 1jzgte vvti our of the verossa jzx110. Pinout and wiring are slightly different. The way to recognize them is by the TB, as one looks like the older 1jz/2jz the other looks more like the jz161 aristo 2jzgte vvti.
 

·
Registered
Joined
·
501 Posts
Discussion Starter #19
To get the motor running outside of the car just follow the verbal instructions on the video. I will make a basic Powers/Grounds diagram to run the motor as well outside the vehicle. It was really easy to get the motor to fire after I had fuel and a fused power source.

I am curious on the other 1jzgte VVTi's. I would like to find out more, but have not found much. Can you get some specific pics of the eng setups to help identify the others? The one I have is an origonal Non-DBW. I had the choice but went the easy route.

Do you know where the pinouts differ between the verosa and the chaser?

wow - I'm really impressed by the level of details and all of the info shared (I may have to download it all to keep!). Can you scan your typed-up info to get the engine running without physically putting it in the car?

Also as an fyi there are 2 types of 1jzgte vvti - The one you got, out of the chaser jzx100 and then the 1jzgte vvti our of the verossa jzx110. Pinout and wiring are slightly different. The way to recognize them is by the TB, as one looks like the older 1jz/2jz the other looks more like the jz161 aristo 2jzgte vvti.
 

·
Registered
Joined
·
454 Posts
Hey dude, I have an idle issue with my 1jz vvti swapped FD. Would it be possible to meet up sometime and test your ECU on my harness?? Ive done alot of diagnosis on trying to figure out the issue and I would like to rule out the possibility if the ECU is bad or good. I noticed you live in the Denver area, I live kind of near there...
 
1 - 20 of 103 Posts
Top