Supra Forums banner

1 - 5 of 5 Posts

·
BMM
Joined
·
2,329 Posts
Discussion Starter #1
Hey guys,

This afternoon was kinda rough. First off I'm just driving minding my own bussiness (and doing the speed limit). I see my exit coming up quickly, so I speed up ~5mph to get around this truck that was beside me. Well when I got in front of him the lanes had just barely begun to divide and there were those white lines in the middle. When I changed over (used my signal) I went over those lines, but was in no danger of really missing the exit or smashing into anything. I keep driving for about a mile and whatta ya know.. Red and Blue all up on my shit. So I pull over and the cop comes up. He asks me why I went over those lines, and I told him, "so I could get off at the exit." So he states me for an "illegal manuver" or some shit like that. Then, he gets cocky with me, and I can remember exactly what he said: "Your exhaust seems a little loud today, I should site you for that too." -OK, dick- ...walks up front, "Looks like you dont have a front plate, that'll be another ticket." -SUPER dick- ... "Why dont you roll up your windows for me, that tint looks a little dark." :wtf: . So he takes my info and heads to his car. LUCKILY something changed his mood from being a total asshole to only giving me that illegal manuver BS... But whatever, I left... it pissed me off pretty good.

I start driving again and I notice that I'm a little on the rich side. I kinda brush it off. Then I get into boost and I hit fuel cut @ 7~8psi (my MBC is at 15psi) ?! My WB reads 10.0 for a good 20 seconds then starts to come back to normal. Curiously I see if it happens again. Yup! sure did :faint: So now I dont know why its doing that.. What are some possible things that would cause that? Could one of my MBC connections be loose? I truely dont know what it is. Other than that it drives fine, but its worrying me..

Any help would be great (I'm mainly conserned about my second issue of the day, I just thought that I would share my little story with you guys) :wavey:

Thanks,
-Adam
 

·
Not so boring anymore
Joined
·
7,085 Posts
the cop loosened your boost pipes when he was looking at the non existant front plate.. so you now have a boost leak..
 

·
BMM
Joined
·
2,329 Posts
Discussion Starter #3
I wouldnt be suprised... :) So you think its a boost leak? I guess that makes sense
 

·
Registered
Joined
·
3,877 Posts
cops are dicks....
 

·
BMM
Joined
·
2,329 Posts
Discussion Starter #5
I started peeking around my engine bay and found out that the coupler coming off my turbo to the first IC pipe has ripped almost completely in half :doh: . I think it has seen better days. But no worries, my new pipes and couplers are in the mail! :D So that takes care of my car problem. The cop issue is still open for disscussion.
 
1 - 5 of 5 Posts
Top