Supra Forums banner

1 - 15 of 15 Posts
S

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Today i took the supra out to cruise. We had a cold front hit my area. It was really cold..

So i floor it from a dead stop... It hit 25 PSI of boost at 6,000 RPM.. then it hit rev limiter with it being in DRIVE.... I have an auto 93.5 TT.. with intake exhaust and downpipe, and has a FFCD.. Why am i getting so much boost?!?!?!

So i took her on the highway and floored it... The first turbo was at around 11 PSI... and the 2nd turbo wouldnt come online!!! I think i could have messed something up..

But when i go from a stop it will boost 25 PSI again.. I have no idea whats going on...


What do you guys think?

:eek:
 
B

·
Guest
Joined
·
0 Posts
Discussion Starter #2
Second turbo not comeing online is excatly the same think mine did when it died.

Chris
 

·
Registered
Joined
·
13 Posts
Sounds like you have a lazy pressure tank or something. Back in my sequential days when I would punch it from a roll, sometimes I would only get boost from one turbo...then after I would upshift, the 2nd turbo would come back online. From a stop the 2nd turbo would always come online like it should. I switched permanently to TTC and haven't had any problems since...

I know that doesn't really help, but I don't think you should lose sleep worrying if you blew the 2nd turbo...if you aren't getting the death whine or tons of smoke, you probably didn't. You might try the temporary TTC and see if that fixes the problem.

Dude, sequential sucks anyway...go TTC. The people that whine about the lag just need to learn how to drive IMO. I hated 'double lag mode' ;)
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #4
is there a way to find out if its my pressure tank?
 

·
Moderator
Joined
·
3,148 Posts
Don't worry about your pressure tank. I had the occasion where my 2nd turbo periodically didn't come on line. I am in ETTC now and no longer have that annoyance. I know TTC may be a problem with your auto but I don't think there is anything wrong with your car. You need a Greddy BCC and a MBC (ball and spring type). You have a very expensive car and those two parts together will only cost $200. If your going to do something at least spend the time to do it right.

Later, Steve
 
A

·
Guest
Joined
·
0 Posts
Discussion Starter #6
Check your actuators, as they sometimes can go bad. I thought it was my pressure tank, too, but found that it was OK. Are you getting anything coming online, or is it a slow boost leak?

The actuators are pretty easy to check, and I think they are only about $40 a piece. The only hassle is that there a TON of actuators to check. Let me know if you need specifics...
 
S

·
Guest
Joined
·
0 Posts
Discussion Starter #7
Its very weird, seems like only sometimes the 2nd turbo will not come online. Like i said this is the first time this has happend.. I am running way to much boost.. It spiked 25 PSI last night..

It felt like an NA on the highway when the 2nd turbo didnt boost.

how is the ETTC on an auto?
 

·
Registered
Joined
·
1,038 Posts
I have had the same problem, and others have told me the same thing... I believe its common, one time I had a 94' Z28 next to me on the highway at about 75mph.. when I punched it NO BOOST... boost guage sat at 1-2psi.. and he took off.. I was pissed, because I know that car was no match... sometimes if I let off the throttle fast and punchit again, the turbos will finally respond.. this happens pretty rarely though, which is why I hate racing from a roll SOMETIMES.. but if I put the car in 2nd at that speed no matter what I get the Turbos online ;)

Anyway... after the Z28 got me the first time... I pulled up and waiting for traffic ahead go clear again, made damn sure the twins were gonna come online.. and nailed him EASILY.. so he must have realized I had a little problem the first time after that. :D ... wish I could pull on a Newer camaro that easily, the LS1s are fast.. the older ones pretty much arent :\
 

·
Mechanical Engineer
Joined
·
242 Posts
How are you getting so much boost? Did you pull the hose?
I heard that pulling the hose is not good because if you get a boost spike you car may run too lean and boom. I heard of a guy who hit 28 psi racing a viper and he blew a spark plug. But if you have some thing to control the air/fuel ratio. Then fuck it.:cool:
 

·
Moderator
Joined
·
3,148 Posts
I wouldn't worry as much about the engine as the turbos. The turbos are spinning at a very high rpm's at that boost pressure and the turbo's bearings are not designed for that rpm and heat. If you don't mind getting the dreaded "death whine" than continue boosting to that level, otherwise I would turn down the boost. Your turbo's may last a very long time like that, but they my go out the tomorrow. It's all depends on the risk your willing to take.

Later, Steve
 

·
Senior Member
Joined
·
259 Posts
Hey Joey,

Right before my second turbo died, I was getting on the highway and accelerating rapidly and about the time the 2nd turbo was to come on I got NOTHING!! First turbo was fine but nothing from #2. A few days later after checking everything I took it for a spin and #1 boosted and then when #2 came online it smoked bigtime and thats all she wrote for the turbos!! :(

As others have said...Nick did the ETTC mode to mine and I'll NEVER go backl to sequential!!

I'd take it in and have it looked at!

Jeff M
 
T

·
Guest
Joined
·
0 Posts
Discussion Starter #13
I have a brand new pressure tank and still have that problem on occasion.If I ever quickly downshift and floor it,it makes no boost until I upshift.Also,I drive daily with a pulled hose and my car never boosts higher than 18 psi from a dead stop.Could this be due to the fact that Im still running the stock catback?From a roll in 4th or 5th I can hit 20.5 psi but thats it.

Joe
 

·
Registered
Joined
·
1,038 Posts
The highest I have peaked was 20psi I believe on an Auto with the VSV bypass mod done.. damn some of you guys are peaking HIGH as hell.. its cold outside now I wonder if thats gonna change anything.. my car has been in the shop 2 months, ive never driven it in cool weather yet.. should be fun.. great for racing :D

And... Would the ETTC mod be shitty on an Auto?... I know I can switch back easily with a switch... when do they both come on.. is it 4200rpm or so?... and what is the major benefit of this, will I get any more horsepower... I thought in Sequential mode turbo 1 sung right along with turbo 2 all the way upto rev limiter... TTC just makes them hit at once and feel harder... doesnt it?
 

·
Registered
Joined
·
2,291 Posts
pooshda said:
The highest I have peaked was 20psi I believe on an Auto with the VSV bypass mod done.. damn some of you guys are peaking HIGH as hell.. its cold outside now I wonder if thats gonna change anything.. my car has been in the shop 2 months, ive never driven it in cool weather yet.. should be fun.. great for racing :D

And... Would the ETTC mod be shitty on an Auto?... I know I can switch back easily with a switch... when do they both come on.. is it 4200rpm or so?... and what is the major benefit of this, will I get any more horsepower... I thought in Sequential mode turbo 1 sung right along with turbo 2 all the way upto rev limiter... TTC just makes them hit at once and feel harder... doesnt it?
From what I hear most people don't like TTC on an auto. In TTC both turbo's are online all the time, the advantage is you don't get the boost dip at 3500-4000RPM's like you do in the stock setup, so the power band is smoother. I really like TTC with my 6-speed, it's harder to get off the line and there is more lag, but usually just a downshift will take care of that. You do make more power from 3500-4500RPM's or so, but you loose some down low. The high end should be the same but some people report making more high end in TTC for some reason.
 
1 - 15 of 15 Posts
Top