Supra Forums banner

1 - 5 of 5 Posts

·
supra love
Joined
·
463 Posts
Discussion Starter #1
i found out i the hard way i have a leak with the new 2jz water pump. i bought it from the dealer and i also bought the 6" hose that came with it. there is a hole on the top of the pump and when you turn the engine on it leaks coolant.





the second picture shows the blue line i used to connect the two coolant nipples. i'm starting to guess that these should not be connected this way. did anyone else figure out what to do?
 

·
Banned
Joined
·
1,731 Posts
Autozone 2JZGTE waterpump was a direct replacement for my Soarer 1JZGTE. Cheap too.
 

·
Inline6Performance
Joined
·
1,482 Posts
jizake1jz said:
i found out i the hard way i have a leak with the new 2jz water pump. i bought it from the dealer and i also bought the 6" hose that came with it. there is a hole on the top of the pump and when you turn the engine on it leaks coolant.





the second picture shows the blue line i used to connect the two coolant nipples. i'm starting to guess that these should not be connected this way. did anyone else figure out what to do?
If you have a single turbo, the blue hose should be capped off. That is a cooling line for stock twins. Just cap it off. The one under the water pump is the relief hole. It will only leak when the pump is bad.
 

·
Premium Member
Joined
·
6,638 Posts
NUNEZTT said:
If you have a single turbo, the blue hose should be capped off. That is a cooling line for stock twins. Just cap it off. The one under the water pump is the relief hole. It will only leak when the pump is bad.

agreed
 
1 - 5 of 5 Posts
Top