Supra Forums banner

1 - 8 of 8 Posts
P

·
Guest
Joined
·
0 Posts
Discussion Starter #1
Anyone heard of these guys? These specialize in 3000GT's/Stealths...owner drives a VR4. Very nice shop...thinking about taken my car there is Saturday to see what kind of repairs they can do for me...

:dunno:
 

·
the quest for spool
Joined
·
172 Posts
Yes, I've known the owner and most employees there for 5+ years. I used to have a Stealth, and they have a great selection of in-stock parts, great customer service, and just moved to a large facility with lifts and all services available. Highly recommended by the entire 3000GT/Stealth community. Tell them Brad W. from Knoxville said hi :)

- Brad
 

·
!black
Joined
·
4,625 Posts
I've bought tons of stuff from 3SX when I was into the 3SI platform. Great guys, they weren't far from me when I was out working for microsoft there in charlotte.
 
C

·
Guest
Joined
·
0 Posts
Discussion Starter #4
My roomie works there...

Huge 3000gt shop...starting to get into subbies and evo's..

Dont do ANYTHING toyota (I have an MR2 Turbo). Although, from what I have been told, there going to be expanding into it shortly.

Nice guys though!
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #5
man I'm glad you posted. I was gonna take my car there this weekend.

This sucks guys...findin a good shop is discouraging :confused:
 

·
the quest for spool
Joined
·
172 Posts
What kind of repairs do you need done? They have very competent techs, and unless you're doing something very Supra-specific, I'm sure they could handle it. Might want to call them and see if they can do what you need. John M. is their main tech guy.

- Brad
 
P

·
Guest
Joined
·
0 Posts
Discussion Starter #7
1. Drivetrain rattle. When I accel/decel it sounds like the tranny is moving around. It clanks. I replaced the tranny mount this weekend with no luck at fixing the problem. I read in a few places that it might be the drivers side engine mount.

2. Had a friend hook up my GReddy boost gauge while I was working with the tranny mount. Took the car out for a test drive after I was finished. As soon as I hit 4000RPM in 2nd gear it was like I hit a brick wall. All the warning lights lit up and the car cut off. I set everything back up to stock and ran it again. Everything was running great until the Check Engine light came on at about 5000RPM in 4th gear. As soon as I let up on the accel the light went off.

3. Loosing boost in 1st. As soon I hit 4000RPM the BOV releases all boost and it immediatly starts building again. Only happens in 1st gear though.
 

·
MMA Addict
Joined
·
1,221 Posts
do you have a fuel cut defencer? that might be the problem. well atleast that was my problem for the engine light coming on and hitting a brick wall thing.
 
1 - 8 of 8 Posts
Top