Supra Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
790 Posts
Discussion Starter #1 (Edited)
And my car is still running! Could this be the motor I have been waiting for!?!

Anyways, thought a couple of you might be interested to know my car IS running again, has 400 miles on the new motor and numerous 28-30psi dyno pulls in 3rd gear (up to ~165MPH).

base boost (28psi) - 770RWHP
30psi - 820 RWHP

The car is hitting full boost 600 RPMS earlier than with the old turbo, and if it continues the pickup in power should end up making pretty damn close to the same power as before, even with the non lockup setup I am now running!

Too bad the track here closes next wed, and I can't pick the car up until next thurs probably:( Oh well, I can put miles on it over the winter, and get a few things finished up before the tracks open again in spring.... then turn up the boost a bit more and go for a ride:)

-Ethan
 

·
King of the NA-T's
Joined
·
4,044 Posts
Sweet! What piston/rod combo are you using now? I'm building a bottom end over the winter, any tips are appreciated. :p

What turbo are you running now?
 

·
Registered
Joined
·
790 Posts
Discussion Starter #4
I am running greddy pistons/pauter rods. If I had it to do again I would probably go arias pistons... No particular reasoning or logic behind that though, as I have had zero issues with my greddys:)

My advice is get like 87 different machine shops to tell you your crank is good to go before you assemble your motor! I have now gone through 4 motors in the last 15 months or so, 3 of which broke because of a spun rod bearing with less than 100 miles on them. The other one broke for a totally different reason, which had nothing to do with that (in a nutshell only one side of the dual entry rail ended up getting fuel!).

Anyways, the crank was checked and rechecked, and never supposedly a problem, but I find it odd that I get a new block and crank to use this time and no issues after quadruple the miles we got out of any of the other motors!?

-Ethan
 

·
all motor baby!
Joined
·
410 Posts
Just wondering what big end clearances you were running with the 3 motors that spun a big end? Did you/machine shop do anything differently regarding clearances with this motor? I'm wondering if the clearances were a little tight....

Very impressive numbers.
 

·
Boost Dealer
Joined
·
981 Posts
nice, but wrong forum I think, N/A forum, and you have 30psi?
same _turbo_ as before....

Jeff
 

·
Registered
Joined
·
790 Posts
Discussion Starter #10
Woops also forgot to answer the turbo question. I have a hybrid turbo of sorts... We took my 88 and put an 81 compressor on it, and left the hot side the same.

-Ethan
 

·
SupraForums Manufacturer
Joined
·
3,333 Posts
Ebanks said:

the tracks open again in spring.... then turn up the boost a bit more and go for a ride:)

-Ethan
I got till spring to build then:) Congrats Ethan... You've waited a long time for this:)
 
1 - 12 of 12 Posts
Top