Supra Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
This isnt a supra but i dont see anywhere else on here where there is just automotive discussion so i will try my luck.

were going to hit over 600WHP with this car But my blitz boost controller wont let me !!!!!!!!!
Heres teh deal
1998 Nissan 240sx
RB26dett
All the trimmings u can think of buy well focus on turbo and boost problem for now.
Blitz SBC-ID boost controller
TWIN HKS GT2540 turbo kit with stock manifolds.
HKS Wastegate actuators (they came with the kit)
Custom 3" downpipes
4" exhaust with no muffler (sounds like a motorcycle i love it)
Car is Running AEM EMS with HKS intercooler 4" triple layer GTR application.

SO HERES THE DEAL PLEASE PLEASE PLEASE
i need to know whats wrong
boost will hit 1.1 bar and then just DIE down to .5 bar after 6000RPM it HOLDS at 1.1 bar PERFECT then something just KILLS it!
what could it be?
BOOST CONTROLLER: Manuel settings at SET: 75 and GAIN:35
No matter what i do with the GAIN and SET it does nothing

Auto mode just makes it LAGGIER.
WHAT TO DO im dying and yeah i have a tuner flying in from out west in 2 weeks and NEED to figure this out today!
 

·
Boost4fun
Joined
·
1,848 Posts
Unfortunately I am not that familiar with the Blitz unit but what are the RPM settings of it? What have you set the [email protected] to and how is the behaviour w/o the Blitz being active?
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #4 ·
wel reason i posted this here is since so many supra guys LOVE the SBC-ID and use it so much.
I figured it only has to do with the SBC-ID setup
 

·
Registered
Joined
·
1,249 Posts
The setup sounds good, what do you have the max boost set to? Other than that it should work for you. Boost leak possibly?
 
1 - 6 of 6 Posts
Top