Supra Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,367 Posts
Discussion Starter #1
I officially have 1 week to get my car reliable enough to travel 300 miles there and 300 miles back. It's been throwing wierd ass codes(11, 42, 51, 52) and been bogging like crazy. I don't know what's wrong and I really need to the car running right asap. Please Please PLease help. I already changed my plugs and shit.
 

·
Registered
Joined
·
3,877 Posts
11 isn't in the manual that I see...

42 is vehicle speed sensor

51 is A/C or TPS

52 is knock sensor

They could all be caused by a bad ECU as well, but that's unlikely. None of they are fatal, the car will just be conservative (in other words RICH and not very agressive with timing). That's why it's bogging...

replace/rewire the knock sensors (depends if they're broken or not, if not brokent just rewire em), replace or inspect the speed sensors (maybe disconnected?), and replace the TPS....
 

·
Registered
Joined
·
1,367 Posts
Discussion Starter #3
Knock sensors are new, TPS is new, where the fuck is the vss? LMAO sorry. I already reconnected the knock sensor(connector sucked), TPS has been adjusted, where are the speed sensors located? I basically just want the car to run fine. How do I get it to run a little more lean?
 

·
Destroyer of Turbos
Joined
·
4,461 Posts
usually its not the knock sensors that go bad but the wiring in between. replace that
 

·
Registered
Joined
·
3,877 Posts
pull the EFI fuse and it will reset the ECU (pull it and wait a few...)

won't you get the TPS code if you hit the gas while reading codes? I forget the code that comes up from that...
 

·
Registered
Joined
·
1,367 Posts
Discussion Starter #9
Alright, so I did all of that stuff...what else could be causing all these codes? I'm completely stumped and Friday is only a few days away!
 

·
Registered
Joined
·
1,367 Posts
Discussion Starter #10
Is the VSV supposed to have a filter? Also, does it matter if the VSV is backwards or not?
 
1 - 10 of 10 Posts
Top