Supra Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
34 Posts
Discussion Starter · #1 ·
ok im sure it has been asked a lot so im going to get beat up on here but its my buddys forum name(thanks chris).ok what i need to ask is chris gave me a 86.5 auto supra,thats the nice part,he told me if he has to swap in the gte then i have to pay for the engine but if i learn and can do it mostly myself he would give it to me.i been around him for a few years and i know there are yellow plug (86.5-88) grey plug(89-92).i got lucky and got a 87 gte harness from pull a part and chris let me have a 87 gte auto ecu.chris runs a 5speed with a auto so i know im good there but what i want to know is,if i put the gte in the car and put my gte harness on will it plug up to the ge harness under the dash and will it work without having to cut and splice?I would guess that i would need a boost gauge as its not in the n/a cluster but would that be it? thanks for any and everything
 

· Registered
Joined
·
1,403 Posts
yes, it should work correctly without splicing (at least it did for me). However, your tach won't work correctly so you either need to get a new pcb (the circuit board behind the tach) from a GTE or you need to re-solder new resistors on it. If you search there are instructions on here somewhere for how to replace the resistors. I did it, took me about an hour total start to finish including removing and reinstalling the cluster. good luck with your swap. It's not that hard to do; it was the first mod I ever did to my supra.
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top