Supra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hi everyone,


I recently got an '87 turbo with a BHG and just finished replacing the head last weekend. Everything went together fine and I got the car up and running and put about 50 miles on it so far. Then two days ago, it simply wouldn't start and I can't figure out why.

The engine turns over and is getting fuel to it so I thought the timing had gotten messed up somehow. Pulled the upper timing belt cover off and everything is still aligned and there aren't any bolts stuck down there or anything. Cam position sensor hasn't moved so I guess its not timing. Then I tried taking the intake hoses off and checked the turbo, its still spinning freely.

When I try to crank it however, it turns over and then a puff of exhaust comes out of the intake..

If anyone knows what could be causing this please let me know,

Thanks
 

·
Registered
Joined
·
3,727 Posts
a puff of exhaust comes out of the intake..?? wtf?!

is it throwing any codes?
 

·
Oldie but a Goodie
Joined
·
1,465 Posts
If you have exhaust coming out your intake then you definately have a timing issue. Get a hold of a timing light and check that.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #4 ·
Yea, thats why I thought it was timing initially as well, but I don't know how the timing could have suddenly gotten so much worse that it wont even start when it was running fine the day before. I guess ill try to put everything back in place and check the timing again cause I don't know what else to try at this point...
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #5 ·
Ok, so I rechecked the timing and couldn't see the marks at all. Pulled out the cam position sensor to reset it and it felt harder to spin, and the steps felt less distinct then what i remembered it to be. Tried rotating it around a bit and got the car to start but it would die after like half a second. Is there a way to check if the cam position sensor is still good besides just checking the gaps?
 

·
Oldie but a Goodie
Joined
·
1,465 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
bump

Trying to find another cps to try out but anyone have any other ideas as to what could be causing this?????
 
1 - 7 of 7 Posts
Top