Supra Forums banner
1 - 12 of 12 Posts
G

·
Discussion Starter · #1 ·
So i got this 89 supra turbo, the thing is that every time i stab it then throw it in neutral the idle goes all the way down to 0 and it dies. Im thinking a leak somewhere, i just got done checking all the intake piping, everything seems to be tight and couldnt find a leak anywhere, where else should i check? thanks~!
 

·
It's only the beginning..
Joined
·
690 Posts
Stab?
 

·
Knockin the rod in slopra
Joined
·
811 Posts
sounds like what my car was doing when my BOV broke..
 

·
!black
Joined
·
4,622 Posts
My 89 is doing the same thing. Just took it out for a spin, dies every time you come to a stop (not just from WOT). I'll start going through the car here in a bit.
 
G

·
Discussion Starter · #9 ·
it happens when im WOT or anywhere near WOT... quick stab at the throttle even and the idle drop down to 0 ...

thanks! ive read through the dashpot and that seems to be the answer.. too much fuel not being burned due to mixture causing my car to stall. also noticed that my check engine light comes on for the first 10 mins of driving, im going to pull the codes right now. thanks!

this is my brothers friends car and im trying to fix it for him, BOV vented to atmosphere? wheres the stock BOV located at? and how would i go about this. sorry.. new to the boost :sadance:
 
G

·
Discussion Starter · #10 ·
ive been looking and cant seem to find the powersteering fluid resevoir. :ugh2:

squealing noise that i need to get rid off.
 
G

·
Discussion Starter · #11 ·
the resevoir is the container with the toyoda cap on it right?

also was able to pull the codes; 21, 24, 31, 51 ... can there be anything else wrong with this car? =|
 
1 - 12 of 12 Posts
Top