Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
191 Posts
Discussion Starter #1
hey i remove the egr cooler and put a block of plate...

and i was wondering if its common for the engine to sound so loud(noise/rumble seems to be comming out of were the cooler used to be)

also why is there smoke that seems to be comming out of where the cooler used to be? its very light smoke(you can only see once you turn off the car...) looks to be light blue smoke but i cant be sure....

theres also blue smoke comming out of the exhuast(gutted second cat) stock exhuast system.

when i remove the dp from the turbo i didnt see any oil(in fact it was preaty dry...rusty in a way...so does that mean its not the turbo seal?

im wondering about maybe its the valve cover seal... could it be that? or melted piston?

if its the valve cover seal thing about how much ill it cost(me doing the labor ofcource..

and how do i check if its the turbo seal or valve seal..

when i search this guy said to rev the engine in 4k rpm and hold it there.. he said if theres smoke then its the turbo... is this true?

thanks
 

·
SUPRAF0RUMS TROLL
Joined
·
1,610 Posts
what??!?!?!?! why did you remove the cooler???? you know the block off plates are only supposed to block off where the egr used to be... the cooler stays put... so go back to toyota... spend 30 bucks to get the gasket you just destroyed for the egr cooler... reinstall... and call it a day... im betting because you removed the egr cooler it is fucking with your oxygen sensor and making ur engine run rich

peace

damn newbs not reading instructions... (grumble grumble grumble)
 

·
Moderator, megalos ntabatzis!!
Joined
·
4,409 Posts
BrokenSupra said:
what??!?!?!?! why did you remove the cooler???? you know the block off plates are only supposed to block off where the egr used to be... the cooler stays put... so go back to toyota... spend 30 bucks to get the gasket you just destroyed for the egr cooler... reinstall... and call it a day... im betting because you removed the egr cooler it is fucking with your oxygen sensor and making ur engine run rich

peace

damn newbs not reading instructions... (grumble grumble grumble)
pot calling the kettle black?

Not only did i get a headache reading your thread, wtf does the title even mean? Regardless, unless you plugged the port on the cooler, you are a dumbass. The port on the cooler sends exhaust gasses to the egr valve. all you did was block off the side port, removing the cooler just lets the exhaust get out of the back of the head.

This has nothing to do with your o2 sensor.

Put the cooler back on and figure out what youre doing before you do it. Its obvious you are a noob, so get a professional opinion on the blue smoke.

Ang
 
P

·
Guest
Joined
·
0 Posts
HP - Did you actually take the aluminum cover off the back of the head without blocking the hole on the exhaust side? If so - I think you need to put it back on or block the hole with another cover plate.

I think this is what others are trying to tell you too.
 
1 - 5 of 5 Posts
Top