Supra Forums banner
1 - 20 of 36 Posts

· Registered
Joined
·
713 Posts
Discussion Starter · #1 ·
Hello guys

today I was driving around and just noticed that my AFR shows !!! 9 !!! (at full throttle)

I have TOMEI AFR gauge so lowest it has is 9 and pointer just falls to it

have any advice?

what should I check?

btw car is '97 JDM TT 6sp.
 

· Registered
Joined
·
4,081 Posts
Well you are running a Mines ECU. I would assume the ecu is chipped for a modded Supra. Probably BPU+ and your Supra is pretty much stock. You even have both of your cats still. The Mines ecu probably adds a bunch of fuel because it is tuned for a modded Supra.

Which makes me wonder, why are you using a MINES ecu if you have a stock Supra?
 

· Registered
Joined
·
713 Posts
Discussion Starter · #8 · (Edited)
Well you are running a Mines ECU. I would assume the ecu is chipped for a modded Supra. Probably BPU+ and your Supra is pretty much stock. You even have both of your cats still. The Mines ecu probably adds a bunch of fuel because it is tuned for a modded Supra.

Which makes me wonder, why are you using a MINES ecu if you have a stock Supra?
I bought my car as is (from my friend in Japan)

MINE's ECU was already installed

ECU originaly bought from MINE'S and installed there too (I have all the docs and it says it's mapped for 1.1bar)


when I first drove it, it was much faster and AFR gauge at full throttle showed about 11 (as I remember)




is there anything I should check?

can it be the fault of vacuum leak? I dont know if there's any

but I checked visually and everything looked ok

maybe spark plugs?
 

· Registered
Joined
·
13,982 Posts
Do you have a dyno nearby? Do a couple pulls with their O2 sniffer in your exhaust pipe and compare the a/f values,
 

· Boost Creep
Joined
·
5,052 Posts
Well you are running a Mines ECU. I would assume the ecu is chipped for a modded Supra. Probably BPU+ and your Supra is pretty much stock. You even have both of your cats still. The Mines ecu probably adds a bunch of fuel because it is tuned for a modded Supra.

Which makes me wonder, why are you using a MINES ecu if you have a stock Supra?


+ Infinity. Sounds like its dumping fuel because its confused.
 

· Registered
Joined
·
713 Posts
Discussion Starter · #13 · (Edited)
Do you have a dyno nearby? Do a couple pulls with their O2 sniffer in your exhaust pipe and compare the a/f values,
NO DYNO's at all :(







so here are my spark plugs guys (click for full size)

the gaps seems to be the same as newly bought 3330's










should I change them?







i thought the same about MINE'S ECU but couple months ago everything was normal.
 

· DoRi?
Joined
·
1,064 Posts
Ok at a 9 afr you should have Black smoke coming out of your exhaust at wot. If you dont, the sensor is bad or guage is off. Id change those plugs while your at it just because their out already. Do you feel it buck at all when at wot? Does the car sound like a subaru when you free rev it? Id stop driving it until you find out for sure if the guage is off. If you are really running a 9 ar you could wash your rings out and have mad blow by and low to 0 compression.

Edit: if the tech at a dyno dosent know what he is doing, he could blow your engine with a sniffer. The sniffer will be behind 2 cats and away from the turbos. It will read a different value than the wide band if the wide band is properly installed.
 

· Registered
Joined
·
713 Posts
Discussion Starter · #18 · (Edited)
Ok at a 9 afr you should have Black smoke coming out of your exhaust at wot. If you dont, the sensor is bad or guage is off. Id change those plugs while your at it just because their out already. Do you feel it buck at all when at wot? Does the car sound like a subaru when you free rev it? Id stop driving it until you find out for sure if the guage is off. If you are really running a 9 ar you could wash your rings out and have mad blow by and low to 0 compression.

Edit: if the tech at a dyno dosent know what he is doing, he could blow your engine with a sniffer. The sniffer will be behind 2 cats and away from the turbos. It will read a different value than the wide band if the wide band is properly installed.
i don't see any smoke at least in rear view mirror (no smoke even while free revving)

no buck at all and no scooby sound

the only thing i feel is that the car accelerates not as good as it was till 4K rpm's (turbo's are OK) (maybe it's me?)

and at 4K rpm i feel like a punch :D and it accelerates like crazy :D

oh and sometimes i see that AFR gauge pointer jumps (at free revving, sometimes while acceleration)


DiabloMR2,

i removed 2nd fuse as MKIV.co says

maybe there are differences in JDM and USDM?
 
1 - 20 of 36 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top