Supra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
465 Posts
Discussion Starter #1
I just picked up a Haltech Elite ECU and got my Supra up and running on it last night. One of the big reasons that I switch was to use the traction control feature.

I started looking into wiring last night and found this article.

http://mkiv.com/techarticles/racelogic_Install/index.html

Specifically this picture:



My car was originally an NA...all I need is the ability to grab one of the front wheel speed sensors and I'm good.

Is the above pic the same for both TT / NA models?

Can I just splice into pin 4 on A20 and be done?


Thanks
 

·
Toyota Lover
Joined
·
1,432 Posts
If I remember correctly when I wired my ProEFI traction control up, they are not in the same locations as the TT... Just look up the NA ABS sensor locations for your chassis (online manuals) and you should be able to find them pretty easily... Let me know if you can't and I will dig them up... Text me if you need ;)
 

·
Follow the white rabbit
Joined
·
1,653 Posts
Milon if you could post that I would certainly appreciate it. I am about to wire up my ProEFI and I would like to make sure everything is good to go.
 

·
Toyota Lover
Joined
·
1,432 Posts
Okay guys I will do a little breakdown in hopes to help you out... This is just for information only as I have posted screenshots from the OEM wiring diagrams... Be sure to verify this as some years may differ... My car is a 1995 and it worked perfectly...

So the NA cars do not have traction control from the factory... The ecu is an ABS ecu only and here is the pinout that I used for my car... The pin numbers from NA to TT differ at the ABS ecu, with the exception of the rear left hand sensor... So please use this diagram if you are doing this on an NA chassis...



***NOTE:The diagram below is for TT cars with factory traction control/ABS...



As you all can see, the Front RH, Front LH, and Rear RH are in different pin locations than the NA ABS ecu...

You will need to use one of the front sensors and one of the rear to wire into the standalone... I do not believe it matters which one, as long as you have a Limited Slip Differential and both rear wheels spin at the same rate...

I hope this helps!
 

·
Registered
Joined
·
165 Posts
Okay guys I will do a little breakdown in hopes to help you out... This is just for information only as I have posted screenshots from the OEM wiring diagrams... Be sure to verify this as some years may differ... My car is a 1995 and it worked perfectly...

So the NA cars do not have traction control from the factory... The ecu is an ABS ecu only and here is the pinout that I used for my car... The pin numbers from NA to TT differ at the ABS ecu, with the exception of the rear left hand sensor... So please use this diagram if you are doing this on an NA chassis...



***NOTE:The diagram below is for TT cars with factory traction control/ABS...



As you all can see, the Front RH, Front LH, and Rear RH are in different pin locations than the NA ABS ecu...

You will need to use one of the front sensors and one of the rear to wire into the standalone... I do not believe it matters which one, as long as you have a Limited Slip Differential and both rear wheels spin at the same rate...

I hope this helps!
Milton, I know it’s been more than a decade since this post, but we’re did you find this wiring diagram? I have 93.5 na abs ecu and none of my colors match you wiring diagram. I was hoping there’s one for my year.
 
1 - 6 of 6 Posts
Top