Supra Forums banner
1 - 7 of 7 Posts

·
In The Sonoran Desert
Joined
·
471 Posts
Discussion Starter · #1 ·
I just installed this and noticed some pecularities. At idle it seems to fluctuate between 14.6-15.2, which I figure is normal and ok. Driving around it tends to stay in this region but it really seems to fluctuate around a lot more than I thought it would

Whenever I let off the gas, it goes super lean, i mean beyond 17 and the display shows the three out-of-range bars. Whether I am in gear or not, it does this. Is this normal?!?

I had it dynoed last week and the AFR looked very good, 14.5-15.5 and then around 12.5-13 at WOT (362rwhp on 93 gas, probably around 13-15psi as I cannot see the stupid hks evc screen to properly adjust it)

The sensor is mounted about midway down the dp, about 8-12 inches from turbos

thanks for any insight
 

·
feeding your habit
Joined
·
4,014 Posts
when you decelerate, then engine isn't getting fuel..... lean is normal.

-M
 

·
Registered
Joined
·
1,149 Posts
Eric95TT said:
I just installed this and noticed some pecularities. At idle it seems to fluctuate between 14.6-15.2, which I figure is normal and ok. Driving around it tends to stay in this region but it really seems to fluctuate around a lot more than I thought it would

Whenever I let off the gas, it goes super lean, i mean beyond 17 and the display shows the three out-of-range bars. Whether I am in gear or not, it does this. Is this normal?!?

I had it dynoed last week and the AFR looked very good, 14.5-15.5 and then around 12.5-13 at WOT (362rwhp on 93 gas, probably around 13-15psi as I cannot see the stupid hks evc screen to properly adjust it)

The sensor is mounted about midway down the dp, about 8-12 inches from turbos

thanks for any insight
--------------------------------------------------------------------------------------------------------
Sounds normal to me. At light throttle the ecu keeps making
minor adjustments. When you let off the gas it goes into
deceleration mode. This increases your mileage and is quite safe.
Wayne
 

·
Banned
Joined
·
888 Posts
sounds normal.
 

·
Registered
Joined
·
1,691 Posts
yeah the injectors are basically turned off, so lean it is...no worries
 

·
Registered
Joined
·
2,122 Posts
All normal except wot. 13 is a little high imo. I tune for 11.5.
 

·
In The Sonoran Desert
Joined
·
471 Posts
Discussion Starter · #7 ·
Thanks, guys.

When I get the mapecu in there, i will tune it a little lower at WOT, around 12 or so.
 
1 - 7 of 7 Posts
Top