Supra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
192 Posts
Discussion Starter #1
Hello,
I just installed a brand new Greddy SP in my 94tt, Catback system . After the installation, i see smoke come out from under the hood, close to the firewall. When I removed the two nuts from the cats. I sprayed WD-40 to loosen the nut. after driving a couple miles I park the car and pop up the hood then I see smoke. Is this a normal breaking period???? Please advise.
 

·
boost is good
Joined
·
772 Posts
maybe the wd40 and the heat from the exhaust was causing a little smoke when it was burning off, but other then that you shouldnt get any smoke from that area. make sure there arent any exhaust leaks where it bolted to the factory midpipe then just dirve it more and see if it still is causing smoke.
 

·
Registered
Joined
·
192 Posts
Discussion Starter #3
It drove about 20 miles today after the installation of the SP. I see less and less smoke. but still some smoke and smell... will drive some more after posting this message.
 
J

·
Guest
Joined
·
0 Posts
It's probably whatever you sprayed baking off. You should smell something too. When I first drove around with the SP and would stop, it had a wierd smell. I assumed that was the paint getting heated up or something. It's normal. The smell will become less and less the more you drive it.
 
A

·
Guest
Joined
·
0 Posts
That's nothing. I had a downpipe on my old Grand National I wrapped with heat wrap and then heavily treated with that silicone stuff. Smoke poured off it first time I went driving. After about 10 minutes it stopped and never smoked again.

Same thing here (stuff burning off).
 

·
Registered
Joined
·
192 Posts
Discussion Starter #7
Yup, you guys are right!!!! Stuff in the pipes burned off. No more smoke or strange smell. I love the new look of the SP, it's very quiet. Sound great at wot. This is exactly what i wanted.
 
1 - 7 of 7 Posts
Top