Supra Forums banner

1 - 20 of 57 Posts

·
yeah thats me!
Joined
·
2,570 Posts
lookin good... cant wait till im almost done.... well my wallet will be happy :)
looks great!

-ian
 

·
I'll nevAr go single!
Joined
·
994 Posts
Thats fuckin Beautiful man, I hope mine looks 1/8 that clean when im done.
 

·
Your Neighborhood Pikey
Joined
·
3,341 Posts
Discussion Starter #5
Flea420 said:
Thats fuckin Beautiful man, I hope mine looks 1/8 that clean when im done.

Thank you! I actually need to clean it because it's dirty right now and the flasher from the camera drowns out everything. Once it's running I will do a thorough cleaning again.

- Chris
 

·
Registered
Joined
·
1,902 Posts
congrats man. I'm glad that you got all the little details worked out. I'm still awaiting word on my car. As soon as i get it, i'll send you the email.

Bryan
 

·
Moderator, l337 M0d3r4t0r
Joined
·
12,222 Posts
can't wait... hams give me an update when you get everything running.
 

·
Over 10 years on SF....
Joined
·
7,892 Posts
Video now!
 

·
turbo....................
Joined
·
1,057 Posts
thats looking awesome, make sure you get vids of the beast :)
 

·
Your Neighborhood Pikey
Joined
·
3,341 Posts
Discussion Starter #13
Well it cranks but no fire. I think something is up with the Crower cams... When zero'd out, it sputters and tries to start but can't get going under it's own power. I advanced the cam 5 degrees just to see and it wont even try to fire now. I'm going to retard it and see what happens. That should tell me if the cam really is the issue. If so, then I'll put the stock cams back in the car and get a set of HKS 272's.

Needless to say I'm a little depressed this morning.

- Chris
 

·
Registered
Joined
·
1,834 Posts
Hey Hams, we all have your support. Dont get down over your project, you have come a lot farther than a lot of us! Keep up the good work and I'm sure it will work out fine. Keep us posted!
 

·
Your Neighborhood Pikey
Joined
·
3,341 Posts
Discussion Starter #15
UPDATE!

It runs! I spoke with Eric (Zazzn) the other night... He had mentioned on his Crower cams that he pulled off his pcv line and then advanced his intake cam. I did the same thing and guess what? It started up no problem and ran!

At this point due to time constraints, I am going to swap out the Crowers for the stock cams so that the car will run.

Just so you guys know, I was not involved in the Crower GB. I had purchased a set of Crower Stage 2's for my MKIV and ended up machining them for my 1JZ. It seems that the 1JZ does NOT like them.

I think at this point I might consider a set of JUN 272's or HKS 272's for my car.

First thing's first, I need the car running so I can drive it to my new home in Ft. Worth.

Oh Eric... With the pcv line removed, my car was idling at 1200 on a cold idle, and there was no lope on the motor. I couldn't tell that there were cams in the car.

Well, back to you guys later! I am out to the garage to swap cams and get this car running.

- Chris
 

·
Moderator
Joined
·
2,275 Posts
Awesome Chris glade everything worked out.
 

·
Your Neighborhood Pikey
Joined
·
3,341 Posts
Discussion Starter #17
WOW!!!!

It's done, what else can I say!? I haven't driven it yet but upon startup and revving the motor.... WOW... It revs REALLY fast now, extremely responsive. I'm getting boost with my 67 just by revving it now. I'm impressed. This car is going to be straight up scary.

I have the video but I need someone to host it for me...

Simply.... WOW.

Chris
 

·
Registered
Joined
·
794 Posts
Hams, that thing is FUCKING AWESOME!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! :bigthumb:
 
1 - 20 of 57 Posts
Top