Supra Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
701 Posts
Discussion Starter #1
Last night I had to have my car towed because it woudl not start. Iwas able to push start it however it would not idle. The lights were very dim and if I tried to push the gas it would die. So today I got the car home and jumped it. It jumped fine and was idling very well. Once I tried to drive off however the car died. Wouldn't the car not idle if the alternator was bad? In order to start the car it must be jumped again.
 

·
Newbie
Joined
·
11,221 Posts
The battery contacts may be corroded. This happened to a buddy of mine. He can jump start the car, but once he turns it off it wouldn't start again. The battery wasn't making contact to start the car.

To test the alternator, just start the car and take off the negative battery terminal. If the car is still running the alternator is fine.
 

·
Registered
Joined
·
701 Posts
Discussion Starter #3
michaelvanle said:
The battery contacts may be corroded. This happened to a buddy of mine. He can jump start the car, but once he turns it off it wouldn't start again. The battery wasn't making contact to start the car.

To test the alternator, just start the car and take off the negative battery terminal. If the car is still running the alternator is fine.

I happened to have a wire brush with me last night when it died. It was however in the dark that I tried to clean them. lol. I'll try to clean them again and jump the car.
 

·
Registered
Joined
·
701 Posts
Discussion Starter #4
I'm getting 14.0 - 14.1 on my voltage meter now. With AC, and the high beams on its 13.8. I'm really starting to think its the battery.
 

·
When cars say, "NO MORE!"
Joined
·
2,112 Posts
you need to do a load test on the battery...itll prob drop to like 8 volts...also you need to test the amperage the alt is putting out...an alt charging at 14 volts puytting out 1 amp is not good :)
 

·
Registered
Joined
·
701 Posts
Discussion Starter #6
michaelvanle said:
The battery contacts may be corroded. This happened to a buddy of mine. He can jump start the car, but once he turns it off it wouldn't start again. The battery wasn't making contact to start the car.

Thats exactly what it was. I cleaned the contacts thoroughly and all is well. The car started fine without jumping it after I cleaned the contacts up well.
 
1 - 6 of 6 Posts
Top