Supra Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter #1
ok well i finally went and got my supra put the new radiator in it tried to start it but the battery was dead so i had my friend jump start it and i got it running then i was heading back home going like 80 and the car started jerking i look at my gas gauge and it droped to half a tank and was moving i just ignored it but then my car started jerking and then i lost all power it was still running but when i would push on the gas it wouldnt go so after i got it to the side of the road i tried to start it but none of my lights came on.

so do you think maybe my alternator is bad or do you think i have like a bad fuel pump or clogged fuel filter?

i am thinking it is just the alternator but i dont know why that would make my gas gauge drop.
 

·
Registered
Joined
·
78 Posts
Discussion Starter #3
Ok well I am going to replace the alternator.

i have another question my check engine light is on. and i dont know why. the engine has 166,000 miles on it. and at 3000 rpms i can here a rapid knocking toward the back of the engine. spun rod bearing? or sticky valve? a valve would be more of a ticking noise right? one of my friends said it could be a loose rocker. it still feels like it has power
 

·
Registered
Joined
·
2,075 Posts
86.5 supra said:
Ok well I am going to replace the alternator.

i have another question my check engine light is on. and i dont know why. the engine has 166,000 miles on it. and at 3000 rpms i can here a rapid knocking toward the back of the engine. spun rod bearing? or sticky valve? a valve would be more of a ticking noise right? one of my friends said it could be a loose rocker. it still feels like it has power
Loose rocker??? :nono: Not on a 7m.

If your check engine light is on... check the codes, that could give some indication of your problem (or another one).
 

·
Registered
Joined
·
78 Posts
Discussion Starter #5 (Edited)
ok i will try that

thanks

well i am not going to be able to get to my car for a month and i just thought of something since my engine is kinda making a knocking noise which would put it in safe mode right? and use more fuel do you think it got real bad and just started dumping fuel in? cause my gas gauge droped to half a tank but it was going up and down? do you think it was just cause i was running off the battery? oh and i put in 87 octane do you think that could be the cause of the knock?
 

·
Registered
Joined
·
2,075 Posts
The gas gauge needle is an electric needle so if your car is loosing power intermittantly it could cause the needle to bounce. I know when I had a catastrophic alternator failure my in dash LCD screen would close half way and open and close and open ect...

I definately see an electrical check in your future.. take it to pep boys or some trustworthy shop to have them check it out. I have a shop near me that I basically pay their rent every month so they do little favors like this for me.

87 octane could cause the car to ping... bump it back up just to be safe.
 
G

·
Guest
Joined
·
0 Posts
the ticking your hearing is valve shims i bet, take off your valvecovers and check/replace them.
 
1 - 9 of 9 Posts
Top