Supra Forums banner
1 - 12 of 12 Posts

· Oldie but a Goodie
Joined
·
1,544 Posts
Discussion Starter · #1 ·
Well, heard my first turbo death whine in person yesterday... which sucks cause i had just finished making my test pipe a half hour before that. Well, if anyone is interested on how long to4e 50-trim CT-26's last under hard driving... its about 9k miles.

Time to look into SP's lineup.
 

· Registered
Joined
·
3,818 Posts
my turbo is making a wierd noise since i put my ssqv bov on. i have it hooked up right and squeeks freakin loud and long but it kinda sounds like my turbo is like wierd.
got a sound clip?
 

· Oldie but a Goodie
Joined
·
1,544 Posts
Discussion Starter · #3 ·
not at the moment but i'll try to get one within a day or so. I still would like someone else to confirm the sound but i'm 99% sure that it's the turbo based on the fact that i only hear it during boost. Checked shaft play and there isn't any axial but there is a decent amount of radial.. can't tell if it is out of spec but i'm pretty sure that it is.
 

· Registered
Joined
·
530 Posts
Might want to check some other things out before considering it dead. My turbo was making a sound that sounded just like the turbo death whine but it turned out to be my wastegate not closing all the way, which in turn make a whining noise. Couple of washers fixed that problem :D. Also other members have had similar death whine noises resulting in bad exhaust gaskets. Definitly check out thing like that which could be causing a similar noise. But after all, it is an upgraded ct-26 so i'm not saying it cant be death whine considering a good amount of the upgraded ct's go out pretty quickly.
 

· Oldie but a Goodie
Joined
·
1,544 Posts
Discussion Starter · #5 ·
Well, the wastegate is already shimmed (have been running 10psi) and again i doubt that it would be a bad exhaust gasket because it only makes the sound under boost. I'm going to look into things further before scrapping it but i highly doubt i'm going to catch an easy break on this one.
 

· Registered
Joined
·
3,169 Posts
Yeah check where the turbo bolts on to the exhaust manifold. Ive experienced death whine twice and i also had the bolts come loose where the turbo bolts onto the mani and it sounded the exact same as death whine just thought i would let u know.
 

· Oldie but a Goodie
Joined
·
1,544 Posts
Discussion Starter · #9 ·
Well i checked those bolts and yeah, they were all pretty damn loose. However, even after tightening them back up it still whines :(
 

· Stormcock approves
Joined
·
1,887 Posts
When I got whine on my stock CT, I couldn't make more than 2-3 psi. Of course mine conveniently occured half-way between home and college. 150 miles on a flatbed is expensive.
 
1 - 12 of 12 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top