Supra Forums banner

1 - 7 of 7 Posts

·
maximizing slip angles
Joined
·
510 Posts
Discussion Starter · #1 ·
I have single with SAFC II and a BCC.

I keep getting P1405 and then P1406. Turbo pressure sensor malfunction/ Turbo pressure sensor range/ performance.

I checked the harness side of the sensor as per the repair manual instructions and it gives me 5.0 V (range is from 4.5-5.5 v). The repair manual proceeds to have you check the ECU side of the harness. THe problem is that both the SAFC and the BCC are tapped in to the Turbo Pressure sensor wire...

I was wondering if anyone has ever had this before and what they did to fix it. Also any suggestions would be appreciated...

The other problem is that the check engine light comes on right away, I do not even have to turn the car on. With my OBD II hooked up in check mode it will through the code before the car is started...

If this helps, the stock fuel pressure regulator was t'd into the vacuum coming out of the turbo pressure sensor. So my Aeromotive fuel pressure regulator receives its vacuum from the same t.

I am running stock MAF, stock EGR, turbosmart boost controller, tial wastegate, precision turbo...

Car is a 1998 turbo 6 spd.
 

·
Registered
Joined
·
872 Posts
SAFC II tap into MAF wire not Turbo Pressure sensor wire.(USDM?)
 

·
maximizing slip angles
Joined
·
510 Posts
Discussion Starter · #4 ·
sorry, the BCC is the one that is tapped into the turbo pressure sensor. would the BCC itself be causing the MIL?
 

·
Boost Junkie
Joined
·
12,668 Posts
You need to adjust your BCC. If you go to MKIV there is a how to.


Steve K.
 

·
maximizing slip angles
Joined
·
510 Posts
Discussion Starter · #7 · (Edited)
thanks for the help. I pulled the cover off of the ecu and found the turbo pressure sensor wire disconnected from by BCC. plugged it in and good to go.

I guess I learned the hard way to check the simple stuff first
 
1 - 7 of 7 Posts
Top