Supra Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
So i have a 1994 twin turbo 2jz 6 speed. The compression is perfect and she has only 120.000km, the mods are intakes are done, it has a big front mount intercooler, and exhaust is also modified. My issue is that it has a greddy profec boost controller which reads a max of 10.5 psi in all gears, now i can adjust the boost level on the profec but even if i put it over 10.5 psi it will never actually go over 10.5 when i go for it.
Now is there a line that isnt hooked up or something? I would really like to have my car hitting 16 psi every time. Instead it feels slower than my neon srt4 i had. Help please?
 

·
Registered
Joined
·
3,623 Posts
1) You have the boost controller hooked up wrong
2) You will need a BCC (Boost cut controller)
3) Put a downpipe with no cats on

Just by putting a downpipe on your boost will shoot up to 15+psi or higher. You will also gain at a minimum 50+whp.
 

·
Not so boring anymore
Joined
·
7,085 Posts
I would assume you're only running 1 turbo and something is messed up with the sequential. Check all the vacuum lines. You can try to put the car in TTC.
 

·
Boost Junkie
Joined
·
12,616 Posts
Check for a boost leak also.

Steve
 

·
Registered
Joined
·
9,670 Posts
I would assume you're only running 1 turbo and something is messed up with the sequential. Check all the vacuum lines. You can try to put the car in TTC.
This....

Try temp ttc
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Okay thanks, the exhaust does have the cats removed. I will look into the ttc mode, is there any other way to tell if the twins are not working?
 
1 - 7 of 7 Posts
Top