Supra Forums banner
1 - 16 of 16 Posts
G

·
Discussion Starter · #1 ·
I have a question on the brackets for the engine. I am using the stock NA 97 OBDII mounts and wanted to know which brackets for the block. I am also using the aristo automatic transmission.
 

·
Banned
Joined
·
467 Posts
you have to get TT motor mount, it won't fit on the exhaust side.
Call jeff wason or Curt.
If you have $$$$, get a TRD motor mount ( get both side).
good luck with your swap..
 

·
Registered
Joined
·
180 Posts
i used the n/a motor mounts with the aristo brackets. they are a tight fit but u can get them to work with a lot of effort.
 

·
feeding your habit
Joined
·
4,014 Posts
I ran NA motor mounts with no problem

97-98 has the same brackets/isolators for TT and NA
93-96 has the same brackets/isolators for TT and NA

you just have to have the isolators and bracket matched for the year. Use your NA motor mounts/brackets and you will have no problems, the bolt pattern on the block is the same.
 

·
Banned
Joined
·
467 Posts
98mkiv said:
I ran NA motor mounts with no problem

97-98 has the same brackets/isolators for TT and NA
93-96 has the same brackets/isolators for TT and NA

you just have to have the isolators and bracket matched for the year. Use your NA motor mounts/brackets and you will have no problems, the bolt pattern on the block is the same.
Wrong :nono:
You cann't use your NA bracket on exhaust manifold side of 2JZGTE, You have change to TT bracket on the exhaust manifold side, it won't fit..
Last time Curt told me, Parts number is different between NA and TT one.
I did swapped on my 98 NA, 100% sure it won't fit, intake side is ok..
NA motor mount is ok, but recommended to replace it, if your motor mount has alot of miles, while your engine is out side a car, you don't have to do it later, if it is going bad.
 

·
feeding your habit
Joined
·
4,014 Posts
strangely enough, curt is the one who told me the info I provided, which worked just fine when I did my swap.

Go figure, I got the only 97 NA car that had TT motor mounts from the factory. Must'a been my lucky day.

I suppose if there is a question, you could PM curt and he could clarify. BTW, I happen to have a set of 97-98 TT motor mounts for sale for $75 shipped. (not the isolators) They look identical to my NA set.... ;)

Thanks
-M
 

·
Banned
Joined
·
1,890 Posts
I needed a passenger side engine mount bracket as well when I put the Aristo into my 98na.
 

·
Banned
Joined
·
588 Posts
doschk said:
i used the n/a motor mounts with the aristo brackets. they are a tight fit but u can get them to work with a lot of effort.
no way, you can use the driver side N/A bracket but you need the TT bracket for the passenger side.
 

·
Banned
Joined
·
467 Posts
USMCSupra said:
I needed a passenger side engine mount bracket as well when I put the Aristo into my 98na.
what's up Joe??
Samething like what i did mine.
I did ordered from Curt passenger side engine mount bracket, and 2 new motor mount also, when i did on my 98 NA swapped, it like $65 i think for bracket, long time ago..
 

·
Registered
Joined
·
542 Posts
On my 93.5 I used my n/a mounts no problem when I swapped in the aristo motor, However I'm still using the JDM twins....dont know if that makes a difference or not.
 

·
Banned
Joined
·
467 Posts
87toysupratt said:
On my 93.5 I used my n/a mounts no problem when I swapped in the aristo motor, However I'm still using the JDM twins....dont know if that makes a difference or not.
Yes, you can use NA motor mout, but how is about a engine bracket??
you can use JDM twins also, but you cann't boost to 22-23 psi..
JDM turbo 18psi max..i think..
 

·
feeding your habit
Joined
·
4,014 Posts
To those who needed the pass side - did you try the NA or just bought the TT mount before trying it? I had no issues at all.


maybe since mine is singled that is the difference? Does the NA motor mount interfere with the stock twins? If so that explains why I was able to use my NA motor mounts.
 

·
Banned
Joined
·
467 Posts
98mkiv said:
To those who needed the pass side - did you try the NA or just bought the TT mount before trying it? I had no issues at all.


maybe since mine is singled that is the difference? Does the NA motor mount interfere with the stock twins? If so that explains why I was able to use my NA motor mounts.
Like they said, you can used your NA motor mount, but the you have to change engine bracket..
I did used my 98 NA motor mount and bracket, it didn't fit, and i had to ordered from Curt ( shipped over night), and i was stucked in middle..
I am 100% sure, you cann't use your NA bracket on exhaust manifold side...
 

·
feeding your habit
Joined
·
4,014 Posts
go figure, I must have been sniffing glue that day.... darn it.

Could have sworn I took the mounts and isolators right off my 97 NA motor and put them on my TT motor. Some kind little elf must have secretly swapped TT brackets in for me. I never had stock twins, since I took those little peashooters off.... and went right into a T61. ;)

Maybe the NA brackets fit because I had no stock twins?

my lucky day :rofl:
 

·
Banned
Joined
·
467 Posts
98mkiv said:
go figure, I must have been sniffing glue that day.... darn it.

Could have sworn I took the mounts and isolators right off my 97 NA motor and put them on my TT motor. Some kind little elf must have secretly swapped TT brackets in for me. I never had stock twins, since I took those little peashooters off.... and went right into a T61. ;)

Maybe the NA brackets fit because I had no stock twins?

my lucky day :rofl:
Yes, that is why you can use your NA bracket, because with stock twins, there are No room to move bracket around..it was hitting a big heavy Y metal connect to cat converter..
So you can use NA motor mount and engine bracket, if you are going single right away, after swap to NA-TT..
 
G

·
Discussion Starter · #16 ·
I ended up using a passenger side 98 TT bracket and a 94 TT mount. On the Drivers side I used the aristo bracket and the NA stock 97 mount. This is the only way I could get the automatic transmission bracket to bolt up with the auto aristo transmission. I could have used all the NA stuff on both sides, brackets and mounts, but the aristo transmission would not bolt up to the chassis. This is what I had to do. I don't know if the different transmissions make a difference, but that is what I found out with a lot of trial and error.
 
1 - 16 of 16 Posts
Top