Supra Forums banner

1 - 9 of 9 Posts

·
Toyotally Awesome
Joined
·
647 Posts
Discussion Starter #1
Hey there good buddies...got a few questions.

Here is the deal...I have NOTHING done as far as ignition...plug wires, coil, nothing. I do, however, run upgraded plugs--don't know what kind so I'm not even going to try to take a whack at guessing. Mind suggesting a good first mod to the ignition aspect of the POLexus?

In your opinion(s), what kind of boost should/can I run on pump/race gas...(on the current setup) assuming that I'll probably running the 104 in Ethan's garage :). You all have been there and done that, so I thought I'd ask....I've been using Xylol/Xylene with about a quart mix to half a tank...works like a dream--poor man's race gas. :)

I ran 20 psi tonight and the tranny didn't really hold well...so, I'm probably going to run it until it breaks, and save up for a GM tranny or a 6 spd.--still in the air. Don't plan to take the car to any events, so, whooptiddydoop...

Dave S,

The install looks fabulous. The kit turned out great. I thank you again for your help.

here's a pic of the turd:

 

·
King of the NA-T's
Joined
·
4,044 Posts
Hey! Nice looking Lex! Thats a Toyomoto kit, right? Is your tranny still stock? If so I'm surprised it held 20psi at all :) Mine died running 14 psi.

I don't run more than ~18psi on pump gas. Any more than that and I think you risk detonation.

I did my 480rwhp pull with the ignition entirely stock, just cooler plugs. The stock ignition is incredibly good. I've added a HKS Twin Power since I'm gonna run real high boost and spray, you can get a plug-n-play harness for it so there is no cutting of wires. I run the Magnecore KV85 wires.
 

·
King of the NA-T's
Joined
·
4,044 Posts
Yeah, the Magnecores are nice. I had Vitek wires but the guts pulled out of one after doing a few plug checks. The Magnecores are right around $200, the Twin Power is just under $400, and the plug-n-play harness was $35. I run a .030" gap, and there is no misfiring up to 23psi, but I haven't tried more boost than that yet.

Dave S. uses a MSD ignition and coil, you'll have to ask him how that works.
 

·
Toyotally Awesome
Joined
·
647 Posts
Discussion Starter #5
DaveH said:
Yeah, the Magnecores are nice. I had Vitek wires but the guts pulled out of one after doing a few plug checks. The Magnecores are right around $200, the Twin Power is just under $400, and the plug-n-play harness was $35. I run a .030" gap, and there is no misfiring up to 23psi, but I haven't tried more boost than that yet.

Dave S. uses a MSD ignition and coil, you'll have to ask him how that works.
oh yeah...the transmission is built...just don't know what was done to it. It is Ethan's old trans...

I am thinking about going with that ignition setup you have. I've been cruising around at 20 psi with no problems. I am hoping to get 450 rwhp out of it around that area...

Do I just call Magnecore and ask for the N/A plug wires?

Dave, once again, you're the man! Thanks!

-c
 

·
I put up BS Flags
Joined
·
1,023 Posts
Hey Cory,
Hey man im Brett im in the St.Charles area and i have a 93 NA i should be going to springfield next semester so maybe i can see what some of your guys 2JZ-GEs can do. Well anyway i saw that you were wanting the Magnecor wires and i just got some for my NA and i got them from Options Auto Salon. www.optauto.com from what i checked its cheaper to go through them then through the dealer themselves BIG TIME. But just ask for the 2JZ-GE wires which are the KV-85s they are nice. Hey while im here i got the freakin spark plug socket stuck on my plug under the valve cover can anyone tell me if they had this problem and how the hell you can get it out. My plug shouldnt be seized in the heads because i put the anti seize on em but the damn socket wont lego my spark plug!
Thanks
Later
 

·
Toyotally Awesome
Joined
·
647 Posts
Discussion Starter #7
Hey Brett!! How's it going? I think I saw you on Lindbergh going the opposite way when I was driving the Lexus back...

I'm pumped you're coming down here...going to SMS? You'll absolutely love it. I actually love the school.

Thanks for the tip for the wires.

I would say go to the hardware store and get the skinniest needle nose pliars you can find...stick them down in there and yank as hard as you can. This is just the socket, right? You may have rolled the socket over on the plug, but that is very difficult.
 

·
Registered
Joined
·
72 Posts
Cory, at 20 psi you'll be making around 380 rwhp. The most I ever saw on the dyno with that setup was 424.5 rwhp 440 tq...and that was at 28 psi, although it was misfiring at the time.
I run 100 octane all the time in my car and I would run full out 27-28 psi all the time unless I was on a long cruise on the expressway. My ignition consists os Magnecore wires, Denso iridium plugs gapped at .028, an MSD Blaster HVC coil and MSD 6A ignition amplifier. Since the install of this ignition I havent had a hint of misfire at any boost level, period. The stock ignition was good up to about 23 psi with that setup.

Wait till I post some new pictures of my baby..you'll all be in awwww!

Dave S.
 
1 - 9 of 9 Posts
Top