Supra Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
555 Posts
Discussion Starter · #1 ·
My car is a 95 auto NA-T about 1000 miles on with the turbo running 7-10 psi. i have a trans cooler with puller fan. recently ive been noticing my overdrive light blinking on and off while driving, but it drives normal like that. when im driving slow, 2000- 3000 rpms it seems like my trans doesnt know what gear to go into. it shifts up down up down which ever way it feels like. the shifts are extremely slow. its normally happens after say 20-30 min of driving.

does anyone know what i should do? the fluid level is okay, if anything it might be a smidge high.

thanks.
 

·
Now...Whitesupra94
Joined
·
3,287 Posts
the od light flashing means the trans is overheating. you're not really going to be able to get away from that when boosting above 7psi. I mean yea you can throw on another cooler or something but the tranny just cant handle the power and it sounds like its dying.
 

·
<.>
Joined
·
343 Posts
Have you tried replacing your stock dextron II tranny fluid with the Toyota Type IV fluid the TT Supras use? It's been working great on my auto so far though I don't know if that is what's wrong with yours.
 

·
Registered
Joined
·
555 Posts
Discussion Starter · #4 ·
ill give that a try, thanks for the advice.
 

·
<.>
Joined
·
343 Posts
Grason said:
ill give that a try, thanks for the advice.
Make sure you flush out your tranny filter screen before swapping to Type IV tranny fluid. Maybe your filter screen is clogged. :)
 
1 - 5 of 5 Posts
Top