Supra Forums banner

1 - 20 of 28 Posts

·
Registered
Joined
·
87 Posts
Discussion Starter #1
What do most of you guys with the automatics run in the quarter and at what speed when at BPU??
 

·
Registered
Joined
·
87 Posts
Discussion Starter #3
Yes...DP,Exhaust and boost controller. How much do drag radials take off your 1/4 mile time approx??? Thanks
 
9

·
Guest
Joined
·
0 Posts
I run 11.90 at 119.80 mph and 1.87 60' with only, i repeat only down pipe and exhaust. and yes is automatic no work on the tranny and also no vpc, afc, gcc and no chip upgrade. :D
 
9

·
Guest
Joined
·
0 Posts
And i forgot to said that run was with street tires. no drag radials and very happy with the car.
 

·
Registered
Joined
·
87 Posts
Discussion Starter #6
Damn man!!! 11.90 is a great time. What kind of boost are you running? What rpm do you brake stand your car to before you launch and do you use the e-brake? I cant get anywhere near 11.90 with mine. I ran a 12.65 this past weekend at 116.8mph but had trouble hooking up at the starting line. It was very cold out and I would leave the line ok but when my second turbo came online my tires would spin.
 

·
Registered
Joined
·
2,444 Posts
Some times posted are superb. I'll give a best run from Englishtown, NJ piloted by me.

Altitude: basically sea level
Weather: 55-60 deg. F (good baro, dry air)

Car: '94 TT AOD
Mods: Pass. side headlight housing removed, VPC, EVC, custom 3" exhaust, ron millen off-road downpipe
Boost: only 16 psi on stock twins

Rear tires: BFG R1 (intended for road racing, but all we had at the time)

Transmission condition: Horrible slip 1-2, I thought we were walking home on this final run of the night. Stock trans and convertor car had 70,000+ miles.

60': 1.91 seconds
[email protected]: [email protected]

With more boost, BFG DRs, some tuning, and a fresh trans and high stall I think I could've gotten 1.75 60 foot, 118mph, and 11.60s. I love automatic Supra TT's seamless power delivery (keeps turbos under constant load and I think turbos in automatics over a big sampling statistically live longer) and if I had one I'd get them in automatic.
 
C

·
Guest
Joined
·
0 Posts
having same problem, cannot seem to find proper launch technique and spin again when it hits 2nd! high 12's and really getting pissed off!
 

·
SF.com Member #0000000023
Joined
·
1,219 Posts
Thanks :) .....unfortunately I'm just getting to drive the car in the past couple of weeks. The car suffered a spun rod bearing right before I bought it...... just dropped in a new motor and did a boatload of maintenance shit to her. Soon as it's all broken it and a few little issues are take care of, I'm going to be putting in an upgraded fuel system, & tuning her.


-Mike


sleeper said:


Looks like the former Supra of Steve T. is in good hands.
 

·
Nice ass huh?
Joined
·
822 Posts
My god you guys are fast!!!!!! Is that typical for a auto supra? I've never seen one run that fast with those mods:eek:

My friend has one and he only runs low 13's.....what kind of elev. are all you at that run those kind of times. In Vegas we're at 2400' I believe.....and noone runs those times here. Maybe were just a little bass ackwards:D

Keep up the good work.....whatever it is that your doing seems to be working!
 

·
Nice ass huh?
Joined
·
822 Posts
Sorry.....I would like to admit my mistake in the last post. I didn't know what mods make up the BPU phrase. From what one of the post says "only DP and exhaust" and runs 11.90.....then the BPU phrase get's tossed in. I was making my statement on the DP and exhaust time not the BPU's time. I guess with the basic mods I could see something close.....but that still does seem a little fast:eek:
 
J

·
Guest
Joined
·
0 Posts
Ya my friend is only able to pull a 13.2 @ 108 Mph with open exhaust, open intake, and pulled hose.
He's launching hard and its still only pulling a best 2.2 60ft.


How are you guys doing this with even more restriction?
 

·
Registered
Joined
·
143 Posts
I don't see how they are getting that good of times either. I just got my boost turned up to 18psi and run a 13.3 @ 115mph on street tires with a tanabe downpipe, Greddy PE exhaust, BCC, and blitz sbc-id boost controller. I have not purchased a K&N air filter yet cause I'm not sure what direction I am going with an air intake yet and I have not tried running without an airfilter at all to see how much better I get.

How are you guys launching the car? My 0-60mph time is 5.5 sec. I could see getting into the 12's with a 4000 stall. Once the big turbo kicks in it feels like a low 12 sec car but from launch to 4000rpm is the downfall I think.

Swamibob
 
J

·
Guest
Joined
·
0 Posts
swamibob said:
I don't see how they are getting that good of times either. I just got my boost turned up to 18psi and run a 13.3 @ 115mph on street tires with a tanabe downpipe, Greddy PE exhaust, BCC, and blitz sbc-id boost controller.
115 MPH is at least a good trap speed for what you have.

My friends running more boost(pulled), less restrictive exhaust(open), and less restrictive intake(open) and pulls 108 so your doing well. Im just wondering if he's needing to do some kind of maintenance that might help it out. He's done plugs and oil so Im not sure what else should be done
 

·
Nice ass huh?
Joined
·
822 Posts
Swamibob: sorry to go off topic.....but you live in Lakeland huh? That's where I'm from....my whole family lives there. I was just there visiting a couple of months ago.....sure has grown:D
 

·
I am an arms deala!
Joined
·
258 Posts
my best time is:

[email protected]

I continue to make track time improvement without doing anymore mods. I did this on a race gas mix.

My problems start with
1. I have a boost leak that doesn't occur until the car hit 19.0psi
2. I can't get the car to hook up off the line with my Nitto 555's. I should have opted for the R's looking back. 20/20 hindsight's a bitch sometimes.

My best 60' time is 2.1

should be able to get it down to a 2.0 or maybe a high 1.9. that should get a mid to low 12.

Mods:
HKS Ti exhaust
custom 3.5" DP
Blitz SBC-iD
Blitz SUS power Intake
12 volt fuel pump mod
EGR mod
FFCD mod(soon to change to BCC)

I was having some real trouble with launching for a while. Getting the car to hold on the line at 2200 rpms. I learned that I didn't have the e-brake pulled up as far as it could go. double check that when you power brake. Also, when I launch I try to let off the footbrake before the ebrake, helps with some wheelspin. Still trying to perfect the launch.
 

·
Registered
Joined
·
1,440 Posts
HRP TX2K1
60' - 1.989 (I just say 2.0) :)
1/8 - 8.0 @ 92.3
1/4 - 12.264 @ 116

Good mods: DP, Borla, DSBC (getting 1.18kg/cm^2)
Bad mods: Stock airbox/dirty filter, Eibachs, KYB AGX shocks, TRD
sway bars. No weight transfer sucks!

I wanted to get some better times this summer (more mods), but it just didn't happen. :(


John H
 
1 - 20 of 28 Posts
Top