Supra Forums banner

1 - 2 of 2 Posts

·
Registered
94 TT, PHR 6266 on the way, Tanabe DP, MaxAir intake, AEM boost, fuel pressure and afr, MBC, BBS
Joined
·
73 Posts
Discussion Starter #1
ok. searched the forums and had seen a post kind about this issue a few month ago but can not find it again. Any ways i am having a strange problem with shifting gears. Manu mode off floor it from a stop, car revs out first then shift to second and so on. Manu mode on and car in L I mash the pedal and the car accelerates but it always starts off in second gear. Heres the strange kicker. When i get to around 4k rpm with manu mode on and shifter in low. (keep in mind the car starts in 2nd gear with manu on). I get to around 4k rpm and let of to decel and the car will go into first (L) gear on its own. which ecu controls the trans shifting? The transmission ecu or the main engine ecu? Thinking about yanking it out and checking caps and whatnot.
 

·
Registered
Joined
·
48 Posts
You and I have already talked about this.

There are several ECU’s such as cruise control, ABS, TRAC, etc. but the main engine ECU also controls the transmission.

There is not a separate transmission ECU.

I’ve talked to a few on here that had the same or similar problem and it was their ECU. I have this problem, I’ve replaced every sensor and wiring connector possible and it did not resolve it.

As a side note my ECU has been rebuilt.

I talked to a well known transmission builder for our cars and he said that they had one doing this a while back and it was a total shit show to figure out and the issue was never really resolved, enough new parts were thrown at it that it went away.
 
1 - 2 of 2 Posts
Top