Supra Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter #1
i have a auto 95 se, that i swapped the aristo into and im pretty much just bpu. i have 550cc injecters with the warbrol 255 pump. i have straight pipe from the turbo n a cold air intake with a front mount and 3" all around. the only electronic mods i have is a greddy bcc and now the avcr. what would u recommend for my duty cycle and boost % for a daily driver. i want like 17psi or so but i cant seem to hit higher than 15psi, which is wat i was hitting b4 i had the avcr hooked up. also wat did you guys put in for car settings? 6 cyl, 4 spd and throttle up?
 

·
Registered
Joined
·
180 Posts
Discussion Starter #3
thanks but i already tried that, what im asking if what setting on the duty and boost would i need to put in to reach 17-18psi.
 

·
Registered
Joined
·
330 Posts
It sounds like your AVC-R is not hooked up correctly, or you have a boost leak.

You need to tune it just like anything else, the duty cycle for each car will be different. Start low, do a pull, and increase the duty cycle. Repeat until you reach your target.
 

·
Registered
Joined
·
180 Posts
Discussion Starter #5
i believe i had a vacuum leak from my bov, i have the knock off hks doesn't seem to be holding shut.
 

·
Boost4fun
Joined
·
1,848 Posts
He mentioned already that he has a BCC in the car..

@doschk
What do you mean with: 17psi I used to hit before the AVC? What did you have in the car before this? How and where did you hooked you AVC in? Maybe this could help.
While I was BPU I think I had it up to around high 80% or low 90 IIRC but not really sure.
Gerd
 

·
Registered
Joined
·
180 Posts
Discussion Starter #8
i meant i use to hit boost cut at 15psi and then i bought the bcc and it got rid of the boost cut but i still only was boosting 15psi all the way to redline. so i bought the avcr to increase the psi and cant seem to do so.
 

·
Registered
Joined
·
180 Posts
Discussion Starter #11
i have tried numerous different combinations with the boost and the duty cycle, do you think i could just have done the vacuum routing wrong? or would my car run like ass if i did so
 
1 - 12 of 12 Posts
Top