Supra Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
3,326 Posts
Discussion Starter #1
Want to sell it to me? Thanks.
 

·
Registered
Joined
·
184 Posts
What size turbo inlet do you have? 3", 4" or 5"? Were you looking for something aluminum that could be polished or something mild steel that could be powdercoated? I have a bunch of various silicone adapters and spare pipe material if you were looking to do something simple. Are you running a MAF still? :)
 

·
Registered
Joined
·
3,326 Posts
Discussion Starter #3
I'm still running the stock MAF. I cured the problem by having a nipple welded on the intended pipe. Thank you UMS Tuning. I was previously entertaining something temporary.

Do you by chance have an extra oil line (not the return line)? That is the only thing that is preventing me from running my car with new single kit.
 

·
Registered
Joined
·
3,326 Posts
Discussion Starter #5
67dbb BL kit baby. Just a fuel line away from start up. And if I could only find a good power source to tap into for the wideband, i'd know my limits on the stock exu and fuel.
 

·
Registered
Joined
·
184 Posts
I'm still running the stock MAF. I cured the problem by having a nipple welded on the intended pipe. Thank you UMS Tuning. I was previously entertaining something temporary.

Do you by chance have an extra oil line (not the return line)? That is the only thing that is preventing me from running my car with new single kit.
I might have an extra Oil Feed Line but I'm not sure on the length of it. If you still need one hit me up and I can check my garage and also see what AGP has in stock right now.
 

·
Registered
Joined
·
184 Posts
Did you install the kit?!

I'm loosing BPU buddies :(
Time to step it up and join the "cool kids" then! :cool: LOL Hopefully my car should be all finished next month and we can start cruising again. :)
 

·
JZA80
Joined
·
3,114 Posts

·
Registered
Joined
·
3,326 Posts
Discussion Starter #11
i got it mostly together. i think I have an oil leak on the return line -- horrid smell while driving under boost. I'm stalling under breaking or hard blips of the throttle while in neutral. PM if you want to come by and laugh at me getting pissed off at my car.
 

·
damn '02's...
Joined
·
649 Posts
i got it mostly together. i think I have an oil leak on the return line -- horrid smell while driving under boost. I'm stalling under breaking or hard blips of the throttle while in neutral. PM if you want to come by and laugh at me getting pissed off at my car.
Do a boost pressure check.... :) :hay:
 

·
Registered
Joined
·
3,326 Posts
Discussion Starter #13
I'm thinking its an inherent problem with the MAF that is well documented on SF. Some have cured it by getting a BOV recirculation kit. Other folks have had to go map ecu or something or other.
 

·
damn '02's...
Joined
·
649 Posts
I'm thinking its an inherent problem with the MAF that is well documented on SF. Some have cured it by getting a BOV recirculation kit. Other folks have had to go map ecu or something or other.
I've done single kits with the stock MAF and had no problems.... :) In fact, I'll be doing one here pretty soon....I'll let ya know how it turns out. :)
 

·
Registered
Joined
·
78 Posts
i got it mostly together. i think I have an oil leak on the return line -- horrid smell while driving under boost. I'm stalling under breaking or hard blips of the throttle while in neutral. PM if you want to come by and laugh at me getting pissed off at my car.
LOL trust me its not any worse than mine.

Were is the MAF located now? It sounds like air turbulence.
 

·
Registered
Joined
·
3,326 Posts
Discussion Starter #16
next to the air filter
 

·
Registered
Joined
·
3,326 Posts
Discussion Starter #18
i might but will be busy all week. can you pm me your number again
 
1 - 19 of 19 Posts
Top