Supra Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1,229 Posts
Discussion Starter · #1 ·
Ok, when I accelerate mainly in 3-4th gears, If I go WOT when I get to around 4-5000rpm I will get what seems like a backfire, just a 'bang' big hesitation for just a half second. Could my car be running really rich for some reason? I am going to check for any boost leaks tomorrow hopefully. What else may be causing this?

Car is stock aside from K&N filter and BIC DDP (also using porsche spec BPV)

Thanks
Chris
 

·
Republican
Joined
·
8,421 Posts
Fuel cut?
 

·
Registered
Joined
·
1,229 Posts
Discussion Starter · #3 · (Edited)
I dont think so, as its just a big "pop" dead spot power wise, it doesnt completely shut down. Or could this be fuel cut. Come to think of it... thats quite possible... I'll check codes tomorrow as well. Heh. dumb me, overlooking the obvious.

Chris
 

·
Fuel cut is my friend
Joined
·
239 Posts
I get that same POP sound sometimes after I shift after 2nd or 3rd gear. Im running a 3" BIC dp and 3"catback with no cat, and turboXS RFL bov. I don't think its fuel cut because I used to have that before and the car would feel like it hit a wall every time it hit fuel cut.
 

·
Registered
Joined
·
1,113 Posts
its just because the car is running rich i think... my car does it and is stock other then 3" exhaust from stock downpipe back plus k&n intake... usually after shifting out of 1st or 2nd.
 

·
Registered
Joined
·
838 Posts
I have the same problem. I migh think it could be spark plugs or ignition wires. Also migh be boost leak or maf sensor . Also check all ground wires, somebody told me that it migh be ground wire that connected to coil pack who knows.
Good luck
 
1 - 6 of 6 Posts
Top