Supra Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3,235 Posts
Discussion Starter · #1 ·
Well I drove the car around after being down for a while, everything was fine. Shut the car off and went to drive it after a few hours and it was running very rich. Almost to the point that it would start to run rough at around 1200-4k rpms and black smoke coming out of the tail pipe. The current 02 sensor has around 15k miles and probably 25 galons of leaded race gas through it also. I checked it with a voltmeter and get normal reading at idle but at around 2k rpms it reads zero. My question is has anyone had an 02 sensor fail all of a sudden? I had thaught it might give me a warning before it went completely out.

Lawrence
 

·
Alpine Hardtopper
Joined
·
1,096 Posts
It doesn't take much lead to poison the O2 sensor. But it may take time to get in there. Once lead gets in to the sensor itself it's pretty much useless from there out. Sounds like yours is about to fail though....any time the temperature rises (engine RPM or load increase) the sensor will read 0 volts.

When you replace it, you may check the condition of the rear sensor as well. I haven't looked for factory replacement sensors, but I'm sure they can be had fairly cheaply.
 

·
Registered
Joined
·
934 Posts
wow 25 gallons of leaded is alot. i know my friend who runs straight leaded gas for his DSM changes his plug every 5k miles (he barely drives it) which is still every 4 or 5 month
 

·
Supra Owner Since 1996
Joined
·
2,715 Posts
The 02 does seam to fail suddenly. I was alway skeptical when mine went because I didn't want to waste money on something uneeded ($112) so I held out for a couple of days and then the engine codes started coming that confirmed it. I got 8-10 mpg during that time.
 

·
Registered
Joined
·
3,235 Posts
Discussion Starter · #5 ·
Thanks for the replys, I have an extra used one that I will swap in there to see what it does. I will order one today and see if it fixes the problem. If not I will look into other things, like vpc chip etc..

Lawrence
 

·
Very Senior Member
Joined
·
10,067 Posts
My codes did not come up until well after the O2 sensor had actually failed.
 
1 - 6 of 6 Posts
Top