Supra Forums banner
1 - 17 of 17 Posts
G

·
Discussion Starter · #1 ·
I try to start my car, and nothing happens, i got power throughout the cabin, but the engine will not crank at all, so it can't be the alternator right? so now i'm thinkin its the starter.....and clues?
 

· Not ur jizz, not ur bizz
Joined
·
15,378 Posts
is it clicking? is it clicking once or a multitude of times?
 

· Registered
Joined
·
179 Posts
My starter is doing the same thing,I let it sit for a day and it started right up. I'm replacing my terminals and wires tomorrow.
 

· Registered
Joined
·
444 Posts
I have been through SEVERAL starters. DO not Use WORLDWIDE starters; you will replace it every 3 months. Lifetime warranty be damned.
 

· Registered
Joined
·
175 Posts
I am having the same problem. One second the car cranked over fine the next it wont do anything when i try to start it i am going to be changing my starter tomorrow. I tried changing my terminals but nothing. I even tried banging it.
 

· Registered
Joined
·
1,386 Posts
i'lll bet you 20 to 1 it's your relay. i had the same problem with you. i changed every single wire to my starter, and still the same problem. i added grounds, changed terminals, cleaned everything, same thing. i changed my starter like 8 times (got pretty good at it too), and same thing. finally, i gave up, and bypassed the starter switch and installed a jumper wire to the starter engage wire (smaller of the two wires). i took that and touched it to +battery whenever i had the problem, and BOOM, always worked :).
 
1 - 17 of 17 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top