Supra Forums banner

1 - 15 of 15 Posts

·
Registered
Joined
·
303 Posts
Discussion Starter #1
hey guys im on my 2nd BRAND NEW battery and i dont know what the hell keeps draining my shit. and no, its not the alternator, my meter says that its charging the battery at 14 volts... Also my anti-lock brake dash light is on as well as my tail light dash light. Anyone has any ideas??

oh, my car is an 88 turbo model with a 1jz swap
 

·
Frozen Lake Driver
Joined
·
1,292 Posts
E-brake on is low brake fluid. (can also be caused by ABS light)
Tail light bulb in the dash means you have a tail light bulb out so replace those.
Check all your grounds make sure all is good and make sure there is nothing pulling a charge while the car is sitting.
 

·
Registered
Joined
·
872 Posts
Do as was said above. . .

Personally I think you have a short somewhere. . .
 

·
Registered
Joined
·
1,198 Posts
^ could be a draw SOMEWHERE... which sucks cause it could be anywhere. if you cant figure it out, crawl around with a multimeter when youve got some spare time. look for brittle/burned/cut/shitty wires. how long does it take for the batteries to die? im guessing overnight, cuz if youre driving it daily the alt will charge it while driving between stops.
 

·
Registered
Joined
·
303 Posts
Discussion Starter #5
i remember buying a new battery for the car and then drove it around for like a day or 2 and then it goes bad on me. I think it may have a short somewhere... but i need to get her up and going soon cause my wife just found a job so we'll need the extra car.

anybody else with any experience like this before?
 

·
Registered
Joined
·
1,309 Posts
I'd just try to go over any custom wiring that was done to do the swap seeing as its not by toyota and who knows how well it was done. Do a current draw test and see how much is being eaten and sometimes that can help decide whats doing it.
 

·
NO SOUP 4 U
Joined
·
1,683 Posts
Have you added anything new to the car recently? Alarm? Radio? What sort of work have you done to the car? Got any things not working? Are you blowing any fuses?
 

·
Registered
Joined
·
59 Posts
Im having the same issue with my car. If I let it sit more than just overnight, the battery will be dead. Ive tried three other batteries and even after a motor swap it still happens. definitely subs. to this thread.
 

·
NO SOUP 4 U
Joined
·
1,683 Posts
I figured rather than post in here i would write another tech article on how to find these shorts and battery drains. I hope it works for you guys. I know i use to hate finding wiring problems. Ive used this method for over 30 years. It works.
http://www.supraforums.com/forum/showthread.php?t=617798
 

·
Registered
Joined
·
303 Posts
Discussion Starter #10
I'd just try to go over any custom wiring that was done to do the swap seeing as its not by toyota and who knows how well it was done. Do a current draw test and see how much is being eaten and sometimes that can help decide whats doing it.
well, i ddi put a push start button on the car. my stock alarm came on one time and it might have damaged the wire that signals the starter when the clutch is pressed down for you to turn the key and start the car.

so instead of fixing that wire, i just routed up a a wire connecting my starter to a push start button set up.

i wonder now though if the wire that is suppose to send the signal to the starter to ingite the fuel in the combustion chamber might have other duties other than sending messages...
 

·
Registered
Joined
·
747 Posts
Easiest way to find the draw. Disconnect the POS battery cable end and hook up a multi meter set to amps to the POS battery post and the other on the POS cable end. Then with the key off unplug one by one all of the fuses watching for the draw to drop or go away. If nothing with that do the same with the relays. Now once you have found which Fuse or relay the draw is coming from, find out what is all controlled on that circuit. Then basically trace wiring or the Find which thing causing the draw. It's the best/easiest way I was taught. Good luck!
 

·
Registered
Joined
·
234 Posts
WuTang is that 3 turbos on a 1jz? is that photoshop?
Its shopped. All the jaggies around the turbos, uneven lighting and the oil line going to no where say photoshop to me. :p
 
1 - 15 of 15 Posts
Top