Supra Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
807 Posts
Discussion Starter · #1 ·
Currently I have an Interstate battery that came with my car when I bought it a month or so ago. My positive terminal is all corroded and nasty. And all the area underneath my battery is coated with dried up fluid. It looks disgusting. Any ideas to help fix my problems? I tried cleaning it with baking soda/water and coating it with grease but it still corrodes. Plus my battery tie down thing is messed up from the corrosion as well. I'm considering just purchasing all new equipment from Jay Marks as well as an Optima. Whats the difference between the red top and the others? Also, how much do they run? What does everyone reccomend?

Did the stock terminals have a cover over them with a + on it for positive?? All I have are the two wires with small pieces of metal on the end. Here's a picture of what I'm talking about. You can see the new terminal the previous owner put on before he sold me the car on the left, corroded. I know it's new because I found the old one sitting far down in the engine bay when cleaning. Anyway, all advice and/or help is appreciated.



Matt
 

·
Registered
Joined
·
807 Posts
Discussion Starter · #2 ·
Anyone?
 

·
Registered
Joined
·
807 Posts
Discussion Starter · #4 ·
The cables themselves aren't corroded, just the terminals. The positive never had a cover on it. I sent an request to Jay Marks and am just going to order all new tie down piece and terminal covers. I'm sawing off the positive terminal today. Why saw you ask? Because it's corroded on and the screw is hollowed out. Fun stuff.

Matt
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top