Supra Forums banner

1 - 10 of 10 Posts

·
regretfully supraless
Joined
·
1,331 Posts
Discussion Starter #1
My temp gauge has not spiked at all, but when I cut off the car after driving a long time, I can hear gargling of coolant...I don't have the $ at the moment for a HG job...is it blown? My oil is not milky and my coolant is not brown...am I just overheating?
 

·
Registered
Joined
·
5,966 Posts
I would check the smaller and easier first. I am giving you this advice 'cause i was given the same advice with a similar problem. Saved me a lot of money. I was ready to pull the head off.

I wuld check for leaks, Air in the system, and the most important of all, the condition of the radiator.

My radiator was brand new, and after months, it started overheating. I could not figure it out untill last weekend when I really delved into it.

Here is a post I made. You can follow the advice I was given and the fixes I have posted.

If you are hearing garglin after driving, it could possibly be coming from your coolant overflow tank.

A possiblly bad Thermostat or Partially blocked radiator.

Replace your thermostat, and then flush your system using any of the coolant flush chemicals.

I used Prestone's Super Flush.

Here is a post I made. You can follow the advice I was given and the fixes I have posted.

http://supraforums.com/forum/showthread.php?s=&threadid=266847
 

·
regretfully supraless
Joined
·
1,331 Posts
Discussion Starter #3
It is a brand new Koyo radiator. But I will check everything you said...b/c I don't really have symptoms of a BHG.
 

·
Registered
Joined
·
5,966 Posts
Mine was a Koyo as well. Luckily I bought it from a place where it has a lifetime warranty so it did not cot me a penny, just my time.

BTW, When yo replaced your radiator, did youflush your system completely??

I did not do it to mine, and I think that is what came and bit me in my @#@$$. :)
 

·
regretfully supraless
Joined
·
1,331 Posts
Discussion Starter #5
Well, my boyfriend did it while I was at work...I would assume he flushed it. But I might do a complete flush w/ chemicals now anyways...
 

·
Premium Member
Joined
·
5,301 Posts
How long ago was the flush done? After you initially drove it after the radiator was installed, did you recheck the coolant level? You may just need to put more in. Do a leakdown test just to make sure though.
 

·
Registered
Joined
·
3,123 Posts
My guess is thermostat. When the system was flushed was it replaced? If the jiggle valve is not placed at the top (or is it bottom?) then you will keep getting air in your system, hence the gurgling.
 

·
Registered
Joined
·
5,966 Posts
blackout_89t said:
My guess is thermostat. When the system was flushed was it replaced? If the jiggle valve is not placed at the top (or is it bottom?) then you will keep getting air in your system, hence the gurgling.

Jiggle valve will be on top.
 

·
Banned
Joined
·
2,386 Posts
are you using dealer red antifreeze..strongly reccomend it
 
1 - 10 of 10 Posts
Top