Supra Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
907 Posts
Discussion Starter #1
I was scared tonight. I changed the plugs only to find out oil was all over them and i had a bubbling sound coming from the dash. I'm immediately thinking blown head gasket. I do some searching on the forum and people say that "you'd be surprised how loose the valve cover gasket bolts are". I checked them and they were definately SUPER loose, all of them! No more oil leaks for me :)

Next I park my car on a hill and pop the cap open while idling, No more bubling fo rme!

THanks Guys!!!

(Now I just need to find out where all my power is and why im running lean)

-Mike
 

·
On 2 wheels
Joined
·
750 Posts
Good to hear, what did you torque them to?

Btw, this was starting to sound like a MK3 thread for a second ;)
 

·
Registered
Joined
·
907 Posts
Discussion Starter #3
I didnt have my a torque wrench at the time so i just tightened them by hand to not super tight, But tighter than they were none the less.

-mike
 

·
EchoDeDupra
Joined
·
4,122 Posts
where are these bolts at?... I think I'm going to check mine (can never be to safe :))
 

·
EchoDeDupra
Joined
·
4,122 Posts
what torque setting should they be?...
 

·
Registered
Joined
·
1,066 Posts
I don't know the exact torque specs. I tighten the bolts down till they're snug in a crisscross pattern, front to back. Don't over tighten them or you'll crack the valve cover.
 

·
Registered
Joined
·
907 Posts
Discussion Starter #9
Yeah i just tightened them enough to be snug, knowing im tightening into aluminum. :)
 

·
Registered
Joined
·
907 Posts
Discussion Starter #11
i replaced them and it feels the same
 
1 - 11 of 11 Posts
Top