Supra Forums banner
1 - 20 of 39 Posts

·
900 BHP Club :)
Joined
·
4,923 Posts
Discussion Starter · #1 · (Edited)
The first 2 races against the bike I was on pump gas. I started in 3rd and then shifted to 4th and the boost would creep and my AEM has boost-cut set at 25 lbs. My boost controller was off but it kept doing this.

The next night I had race gas and drag radials and started in 3rd and the same thing except for race gas I think my boost-cut is set around 34 lbs so it was hitting that. I decided to just start in 4th from 60. The bike couldn't hear me spooling so he went when he noticed me starting to move :)

The kid on the bike was super cool and said "Thanks, now you made me all self conscious about my bike." And he's planning to upgrade :bigthumb:

----------

The Viper was a beast off the line. He makes over 400 ft lbs @2000 rpm. It was the first time I've ever raced from a dig on DR's. I was babying the launch so I wouldn't break the rear end. I babied it too much, 2000 rpm launch, and they would stick right away and I'd bog, lol. By the time I started spooling the Viper was too far ahead for me to catch. Plus I had the bad lane so I had to let off early to get behind him for the curve in the road.

I raced a 12 second 240sx with a skyline motor in it and was able to launch well and beat him but it was on our way out so we weren't filming.

I'll keep practicing and see if I can get closer to that viper :)

I put my excuses in the video as well because I'm sure it will make it further than supraforums and I didn't want people to see a supra getting owned by a viper w/o reasons :)

Video: Right click, save as - 10MB * yes my DR launches sucked but I will only get better :) *
 

·
Supra Owner Since 1996
Joined
·
2,715 Posts
Good stuff. Keep praticing for our team event competition coming up.
 

·
Premium Member
Joined
·
6,637 Posts
do you have a boost leak to be hitting fuel cut so often, i would look into that before i do any more racing.

and you really need to learn to launch, use your 2step or something.
and it seemed like you were shifting very fast in the race with the viper, lie you was revving to 65-7k and shifting?!?

what gives?
 

·
900 BHP Club :)
Joined
·
4,923 Posts
Discussion Starter · #7 ·
2jzMK3 said:
do you have a boost leak to be hitting fuel cut so often, i would look into that before i do any more racing.

and you really need to learn to launch, use your 2step or something.
and it seemed like you were shifting very fast in the race with the viper, lie you was revving to 65-7k and shifting?!?

what gives?
I don't think I have a boost leak but I'll check. something is weird about starting in 3rd and shifting to 4th and my wastegate won't open.

as far as launching goes please read what I typed above. but in short, it was my first time ever on drag radials and I had to go up against a viper w/o ever launching on them before. I got the hang of it by my 4th race and beat a 12 second r33 powered 240 but we didn't get that on tape. It's not like I was racing close to home. I was 5 hours away and didn't need a broken diff.

I have a stock engine and I shift at 7k (redline). Maybe it's my super light exedy flywheel that makes the rpms climb so fast and makes it sound like I shift early.
 

·
I'm back!
Joined
·
6,712 Posts
Hey brother...I wouldn't worry about the rear end. I launch off the 2 step at 5600rpm's on drag radials with no problems. If you're really really worried about it, don't heat the DR's and they will spin and not hook so hard.
 

·
900 BHP Club :)
Joined
·
4,923 Posts
Discussion Starter · #10 ·
WICKED SS said:
Nice races :bigthumb:
I would look into the 2 step and run the Viper again. When you ran the Viper were you running 34psi?
Yeah I will work on that. Didn't really want to push my diff that far from home.

The first time I ran 24psi, 2nd time 30psi.

We'll run again later this summer. All those guys are my buddies so we just got together to do some fun runs. We're going to race from a roll too.
 

·
Registered
Joined
·
1,419 Posts
Fun vids.
But it does seem like your power band is way too short. You're making peak HP at 7k rpms, when you shift. Raise the limiter and enjoy the pull ;)

And you never started reeling in the Viper. Make sure you're still making the correct HP. A stock Viper should be a joke :)
Goodluck.
 

·
900 BHP Club :)
Joined
·
4,923 Posts
Discussion Starter · #12 ·
braddman said:
Hey brother...I wouldn't worry about the rear end. I launch off the 2 step at 5600rpm's on drag radials with no problems. If you're really really worried about it, don't heat the DR's and they will spin and not hook so hard.
Thanks. I'm going to practice with my 2-step next chance I get. Mine's set at 4500.
 

·
900 BHP Club :)
Joined
·
4,923 Posts
Discussion Starter · #13 ·
Taimur said:
Fun vids.
But it does seem like your power band is way too short. You're making peak HP at 7k rpms, when you shift. Raise the limiter and enjoy the pull ;)

And you never started reeling in the Viper. Make sure you're still making the correct HP. A stock Viper should be a joke :)
Goodluck.
Yeah my powerband does feel really short. I hear the turbo start spooling then it hits hard and it's time to shift. I need cams so it will widen the powerband a bit and then I can rev higher safely as well.

Here's my dyno sheet to show the short time that I'm making the power.

 

·
900 BHP Club :)
Joined
·
4,923 Posts
Discussion Starter · #14 ·
viper's dyno sheet

 

·
Registered
Joined
·
179 Posts
Nice runs man considering your boost cut issue & hopefully ya get things work better next time & run them again :bigthumb:

Good luck !!

peace
 

·
I'm back!
Joined
·
6,712 Posts
DrMike said:
Yeah my powerband does feel really short. I hear the turbo start spooling then it hits hard and it's time to shift. I need cams so it will widen the powerband a bit and then I can rev higher safely as well.

Here's my dyno sheet to show the short time that I'm making the power.


Holy???!?! 1500rpms of power? What's up with that?
 

·
900 BHP Club :)
Joined
·
4,923 Posts
Discussion Starter · #17 ·
braddman said:
Holy???!?! 1500rpms of power? What's up with that?
lol. stock cams?
 

·
Premium Member
Joined
·
12,615 Posts
Nice! :D

BTW, seeing the old Reverseshocker.com address brought a tear to my eye. Rest in peace, daily porn thread... :sadwavey:
 

·
Slow Talking Salesman
Joined
·
409 Posts
DrMike said:
Yeah I will work on that. Didn't really want to push my diff that far from home.

The first time I ran 24psi, 2nd time 30psi.

We'll run again later this summer. All those guys are my buddies so we just got together to do some fun runs. We're going to race from a roll too.
Thats cool

I forgot your on a complete stock motor, I thought you had a ported head and cams. Get some cams and shift at around 8k.
 
1 - 20 of 39 Posts
Top