Supra Forums banner

1 - 14 of 14 Posts

·
Registered
Joined
·
383 Posts
Discussion Starter #1
Hi so my blinkers have been out on my 94 mkIV turbo for years.... hazards work and left blinker works but if I click the right blinker the flasher makes a horrible noise and it doesn’t work..

84329-14030 looks like the part number to the blinker switch but it’s dicontinued..

Not sure if I should buy a celica or corolla headlight multifunction switch and try to sway the part over and hope it works? 😐
 

·
Registered
1987 Supra Turbo R154 Pearl White, Blue Velour
Joined
·
503 Posts
Are you getting a bZZZZZZZZZZZZZZZZZZZZZZ sound? If so, its either a bulb or the wiring to the turn signal has a flaky connection.

I'm working through the same issue with my MK3. The wire that goes from the tail light to the side rear marker light is sensitive. Literally with the blinker on, if I move it just a bit it goes from click click to bzzzzzzzzzzzzzz and back to click click.

I think your switch is probably fine.
 

·
Registered
Joined
·
383 Posts
Discussion Starter #6
well I checked the harness, looks fine...
I also took out the switch, the switch is also fine..... I actually don’t have front blinker sockets.. took out the pods and sockets, I wonder if I should buy a socket just to see if it acts any different
 

·
Registered
1987 Supra Turbo R154 Pearl White, Blue Velour
Joined
·
503 Posts
Also, my tail light harness "looks" fine, :), but wiggling it reveals the fault.
 

·
Registered
Joined
·
383 Posts
Discussion Starter #9
Thanks bro, gonna order some sockets and see if that’s it... lol, idk why I’m trying that last
 

·
Registered
Joined
·
383 Posts
Discussion Starter #10
I had been checking the front harness.. took out the right rear taillight and the harness had oil all over the wires and there are 2 wiretaps not sure why they are there... hopefully that is the issue...
part of the problem is previous owner put all kind of city lights and strobe lights all over the car... I took it all out after I bought it, but all his hacking at the harness worries me
 

·
Registered
1987 Supra Turbo R154 Pearl White, Blue Velour
Joined
·
503 Posts
I've read several articles on the site that mention guys chopping up that front harness


 

·
Registered
Joined
·
383 Posts
Discussion Starter #12
Got my blinker working.. previous owner put leds in the rear turn signals... they were both still lightening up for hazards and left worked correctly so I didn’t think the bulbs were the culprit..
But I took out the led bulb and resistor and put a normal bulb and all is working like it should now....
Thanks for the help @Dumeinao !!
 
1 - 14 of 14 Posts
Top