Supra Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
240 Posts
Discussion Starter #1
well guyz my car has always burned a lil white smoke for the first 30 seconds after startup...i've driven the car now a total of 2k miles since first getting the clip from jarco back in august...i just installed trev's dp adn ypipe combo...took the car out and within like 20min...the car started smoking white really really bad...so bad it looks like my dads truck when he blew a headgasket on his 22re....i dont think its the head but i think its the turbo seals...any input here would be great...i am in a vise here with my situation..i am honestly thinkin about just unloading this car and selling it...just cause i am so frustrated...with all the lil things that have gone wrong in the last 4months..lmk what you all think....thanks

andrew m.

btw...would bad turbo's be something jarco would think about replacing since i've only put 2k miles on the motor since i got it...i am honestly quite disappointed..but i still luv how the 1j pullss....
 

·
kaizen Motorsports
Joined
·
1,402 Posts
Well it sounds like the turbos are shot. Jarco doesn't warrantee accessories, like turbos and other related stuff. I don’t warrantee stuff like turbos, but there is a member of this forum that I did that for, and now claims that Jarco is better and that their clips don’t have issues. Call Jarco and see if they would do anything for you, it won’t hurt to try. Good luck!
 

·
Registered
Joined
·
240 Posts
Discussion Starter #3
i didn't really expect turbo's to be under warranty so o well...but yea now i need to hunt a good set of turbo's...
 

·
Registered
Joined
·
240 Posts
Discussion Starter #4
just talked to mike @ jarco and he said that i should check and replace my PCV valve and possibly throw in a catch can...and that all this could fix my problem...please help
 

·
Akai Suisei - 赤い彗星
Joined
·
10,377 Posts
Pretty sure your turbos are shot...
 

·
Not so boring anymore
Joined
·
7,085 Posts
another vote for the turbos.. yea after 2k miles i dont think there is anything they can do.. I think they do offer a startup warranty on the stuff (as most do).. but not sure...
 

·
Registered
Joined
·
240 Posts
Discussion Starter #7
could it be my valve stem seals? is their a way i can check to make sure its not my valve stem seals
 

·
Banned
Joined
·
1,731 Posts
Welcome to the world of Toyota.

$200 and u can have good turbos at your door by early next week.
 

·
Registered
Joined
·
240 Posts
Discussion Starter #9
i know i am planning on buying your turbo's i am just making sure its nothing else before i purchase yours buddy :)
 

·
Banned
Joined
·
1,731 Posts
andrew18 said:
i know i am planning on buying your turbo's i am just making sure its nothing else before i purchase yours buddy :)
lol thats fine, im using them to mock up a downpipe anyways :)
 

·
Registered
Joined
·
240 Posts
Discussion Starter #11
could it be my valve stem seals? is their a way i can check to make sure its not my valve stem seals...that are causing white smoke!!!
 

·
JZA70 448 rwhp everyday
Joined
·
2,994 Posts
any way to discern if burning oil is coming from valve stem seals or turbos???

~scott
 

·
Banned
Joined
·
1,731 Posts
if i overfill my oil to the top of full hot, when its hot. ill get some oil smoke when i idle for a while. I just make sure its halfway between full and add 1qt when the motor is hot and i never have any probs. mobil1 syn 10w30
 

·
JZA70 448 rwhp everyday
Joined
·
2,994 Posts
hopefully thats my problem, my oil kinda goes a little above the top of full once its warm, at cold it sits at full.

~scott
 

·
Registered
Joined
·
240 Posts
Discussion Starter #17
Dont Every Say "bhg" Again, Thats Why I Threw Away My 7m :)
 

·
67mm of pleasure
Joined
·
852 Posts
Its your turbos Andrew, Ive never seen something smoke that bad before lol
 

·
Registered
Joined
·
240 Posts
Discussion Starter #19
lol you crack me up todd!! i'll let you know when i get it fixed..i just bought new turbo's
 
1 - 19 of 19 Posts
Top