Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
341 Posts
Discussion Starter #1
i backed out my car out of my garage to wash the car and noticed a clicking noise coming from my engine bay. I popped the hood and was able to find the noise coming from the solenoid of the apexi avc-r. i went back into my car and looked at the control unit. on the display it reads 2.78 BARS of BOOST in idle!!!!! the rpm readings on it also is not correct (i idle at 1000rpm and avcr is reading 128rpm). Okay... so i took my car around my neighborhood for a spin and the damn thing wont let me boost past .5 bars (i was able to read teh boost from my HKS gauges). Do you guys have any idea what is wrong with my boost controller?

Would it be a possible loose connection somewhere??? and if it is a loose connection, why is it making that clicking noise?

And the most feared outcome, if it is broken, WHAT KIND OF BOOST CONTROLLER SHOULD I BUY? I was thinking of getting the HKS EVC IV, Blitz Dual-SBC or the Blitz SBC-iD. Please help me out guys. I need as much information as i can get tonight. Cause if it is broken, i will be ordering the new boost controller asap tomorrow morning thru my distributor.

THANKS ALOT FOR YOUR HELP IN ADVANCE. WISH ME LUCK
 
S

·
Guest
Joined
·
0 Posts
Sounds like you have a bad solonoid... or maybe a vacum leak somewhere... if the boost figure is off I would think that that there is a leak somehwere (a) or solonoid (b)

Or for that matter the entire unit might be bad... I dont nessesarly think that, but its a possiblity.
 
B

·
Guest
Joined
·
0 Posts
SagaSupra

Did your pressure sensor get wet in any way? If it did then it is giving off bogus readings and causing your solenoid to click because it thinks it's doing it's job by controlling boost. This same problem happened to me before. Before you change boost controllers or order parts, do this first. Remove the pressure sensor from the car and disassemble it. It only needs a very small amount of moisture to mess the readings up. Don't forget to remove the inner chip board inside. Should be 2 screws on top and two on the inner board. Make sure it's completely dry inside and I think you'll be ok. BTW, don't listen to everyone who says the AVCR is junk. It just needs more patience to tune and mine hols boost just fine.

Scott H.
 

·
Registered
Joined
·
341 Posts
Discussion Starter #5
well... what do you guys know about the AVC-R and a single turbo upgrade. If things are going according to my plans...then i should be able to be sporting a Greddy T78 or T88 early next year. I would say around February or March. So does the AVC-R work well with that? any other boost controllers that will work good with the Greddy Single?
 
1 - 5 of 5 Posts
Top