Supra Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
305 Posts
Discussion Starter #1
Hello Everyone. I have done a search on this and came up with nothing that answered my question, so I am going to try now. I have a 94 tt six speed. For mods, its got a downpipe, HKS superdrager, bleeder T,BCC and the 12v pump mod. My problem is this...Now that it has gotten colder, I have been hitting boost cut alot more often even with the BCC installed. I tuned it to the specs on MKIV.com when I installed it also. It cuts out at about 18psi which on my car is between 4500-5500 rpm when I am really getting on it. I am running the stock plugs on stock gap as well. I have also played with the adjuster on the BCC in both directions trying to get something better out of it with no luck. I have pulled the EFI fuses to reset the maps as well with no luck. Any info would be greatly appreciated as I would love to fix this.
 

·
488ci V10 Power
Joined
·
1,785 Posts
Are you sure its boost cut and not a spark misfire? For BPU carrs you should be running about a .30 gap on the plugs. Stock gap will miss all day long.

Get some new plugs, gap them to .30, and try again. If you know for sure your BCC is tuned right, then i cant think of anything else.
 

·
REVTECHRACING.COM
Joined
·
2,675 Posts
well, heres my 2 cents. i am bpu++ and run low 11s at the 1/4 and i use denso ik22 plugs at there gapping and have no problems up too 20psi. evryone has there prefs. to which plugs are best but like i said its my 2 cents only.
 

·
Registered
Joined
·
131 Posts
I'm with mk4life.... It sounds like a miss, not boost cut. If you're up to 18psi, you're way past the normal boost cut barrier.

I'd get some new plugs and gap them down.
 
1 - 5 of 5 Posts
Top